Bug 2401

Summary: sndconfig not properly writting out to isapnp.conf
Product: [Retired] Red Hat Linux Reporter: jvincent
Component: sndconfigAssignee: David Lawrence <dkl>
Status: CLOSED WORKSFORME QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-04-30 14:48:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description jvincent 1999-04-28 19:34:42 UTC
I would guess this is a result of it writing isapnp.conf
with a (VERIFYLD N) at the top of the file before it runs
the sound tests. I've only seen this with the soundblaster
cards i've tried. I can update with the full error message
tonight when i get home to redo it on the two machines that
i tried it on. This is my first bug report so if more
information is needed please let me know.

Comment 1 Bill Nottingham 1999-04-28 21:44:59 UTC
More information is needed. What is it writing that's causing
it to fail? (The error message and a copy of the isapnp.conf
would be helpful.)  In general, sndconfig just writes the
isapnp.conf that pnpdump hands it, with certain settings
uncommented.

------- Email Received From  jvincent@qa.butlerintl.com 04/28/99 21:43 -------

Comment 2 Bill Nottingham 1999-04-29 15:44:59 UTC
OK, it looks like sndconfig did botch the isapnp.conf
file, although I'm not quite sure how yet. What you can
try:

- remove that /etc/isapnp.conf (the problem is that
it's got about 4 entries for the same card...)
- run 'pnpdump --config >/etc/isapnp.conf'
- run 'isapnp /etc/isapnp.conf' and note the settings it picked
- put these settings in /etc/conf.modules
(there should be an 'options sb' line that should show
you the general format)

Does that help?

------- Email Received From  jvincent@qa.butlerintl.com 04/29/99 11:47 -------


------- Email Received From  jvincent@qa.butlerintl.com 04/30/99 00:28 -------

Comment 3 Bill Nottingham 1999-04-30 14:48:59 UTC
Not really; I'm not sure what happened to your /etc/isapnp.conf;
it basically ended up with the same card entered four
times over, which really confused isapnp.