Bug 246592

Summary: digikam introduces i386 libs into a x86_64-only system
Product: [Fedora] Fedora Reporter: Javier Perez <pepebuho>
Component: digikamAssignee: Marcin Garski <mgarski>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 7   
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-07-03 21:03:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Javier Perez 2007-07-03 10:05:28 UTC
Description of problem:
After cleaning up my Fedora box of i386 libs, right after installation, when I
try to update the system, for some reason digikam.i386 is called into play. Of
course, once this i386 application is called upon to be installed, it brings
back all the rest of the i386 operating system.

Version-Release number of selected component (if applicable):

digikam.x86_64             0.9.1-1.fc7
digikamimageplugins.x86_64 0.9.1-1.fc7

How reproducible:
always

Steps to Reproduce:
1.Install F7 x86_64 from DVD
2. Delete all i386 packages
3. yum -y update
  
Actual results:
digikam.i386 reappears to be updated
a whole bunch of i386 support files are brought into play to be installed.
Expected results:
only digikam.x86_64 should be updated
No i386 support file should be installed

Additional info:
[root@musa ~]# yum -y update
Loading "installonlyn" plugin
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package pidgin.x86_64 0:2.0.2-3.fc7 set to be updated
---> Package liboil.x86_64 0:0.3.12-3.fc7 set to be updated
filelists.sqlite.bz2      100% |=========================| 2.4 MB    00:54

....
---> Package dbus.x86_64 0:1.0.2-6.fc7 set to be updated
---> Package digikam.i386 0:0.9.2-1.fc7 set to be updated
---> Package xorg-x11-drv-nouveau.x86_64 0:2.0.96-2.fc7 set to be updated
............
Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 digikam                 i386       0.9.2-1.fc7      updates            10 M
     replacing  digikamimageplugins.x86_64 0.9.1-1.fc7

 digikam                 x86_64     0.9.2-1.fc7      updates            10 M
     replacing  digikamimageplugins.x86_64 0.9.1-1.fc7

 kernel                  x86_64     2.6.21-1.3228.fc7  updates            17 M

Comment 1 Javier Perez 2007-07-03 10:09:41 UTC
Removing digikam, and executing "yum update" works as expected, no i386 is
introduced in the system.

Comment 2 Marcin Garski 2007-07-03 11:04:01 UTC
How have you deleted all i386 packages?

Comment 3 Javier Perez 2007-07-03 14:20:21 UTC
Yes. I did a rpm -q --queryformat="%{name}.%{arch}\n" |grep i386 to make sure 
no i386 package remained at my computer before invoking the update and it came 
out clean.



Comment 4 Michael Schwendt 2007-07-03 17:49:50 UTC
exclude='*.i?86' packages in your /etc/yum.conf because this is
Yum multi-lib that pulls in the i386 digikam packages


Comment 5 Javier Perez 2007-07-03 19:39:09 UTC
Thanks