Bug 247159

Summary: VIP parameters 'monitor_link' not apply
Product: [Retired] Red Hat Cluster Suite Reporter: xoleron
Component: rgmanagerAssignee: Lon Hohberger <lhh>
Status: CLOSED ERRATA QA Contact: Cluster QE <mspqa-list>
Severity: medium Docs Contact:
Priority: low    
Version: 4CC: cluster-maint, tao
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: RHBA-2008-0791 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 489369 532756 (view as bug list) Environment:
Last Closed: 2008-07-25 19:15:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 489369, 532756    
Attachments:
Description Flags
VIP script modified
none
Path for /usr/share/cluster/ip.sh to disable ethernet check with 'monitor_link=0' none

Description Jonathan Basse 2007-07-05 18:23:26 UTC
Description of problem:
VIP doesn't start if ethernet link is down even if 'monitor_link' is set to '0'

Version-Release number of selected component (if applicable):
RHEL4U4
rgmanage-1.9.68-1

How reproducible:
Easily.

Steps to Reproduce:
1. Create a service containing an IP resource.
2. Bring the target Ethernet link down (unplug the cable).
3. Try to start the resource on the node.
  
Actual results:
The resource won't start until the link is up.

Expected results:
If the 'monitor_link' parameter is set to '0' we are excepting that the cluster
will start the resource whether the status of the ethernet link.

Additional info:
A test script has been provide to a TAM customer.
Found it in attachment.

Comment 1 Jonathan Basse 2007-07-05 18:23:27 UTC
Created attachment 158609 [details]
VIP script modified

Comment 2 Jonathan Basse 2007-07-11 13:37:03 UTC
Created attachment 158946 [details]
Path for /usr/share/cluster/ip.sh to disable ethernet check with 'monitor_link=0'

Comment 13 errata-xmlrpc 2008-07-25 19:15:11 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0791.html