Bug 248097

Summary: ypserv service script report wrong status
Product: Red Hat Enterprise Linux 5 Reporter: John Lau <jlau>
Component: ypservAssignee: Steve Dickson <steved>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.0CC: clothohk
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 2.19-6.fc7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-10-29 19:02:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
ypserv status patch none

Description John Lau 2007-07-13 08:17:41 UTC
Description of problem:

"service ypserv status" always return zero, no matter if the ypserv started or
not.It is because the return value of "status" function haven't been assigned to
$RETVAL so it doesn't go to the exit code.

Version-Release number of selected component (if applicable):

ypserv-2.19-3 (in RHEL5) and any lower version in RHEL4 and RHEL3

How reproducible:
Always

Steps to Reproduce:
1.service ypserv status
2.echo $?
  
Actual results:

ypserv is stopped
0

Expected results:

ypserv is stopped
3

Comment 1 John Lau 2007-07-13 08:17:41 UTC
Created attachment 159133 [details]
ypserv status patch

Comment 2 Steve Dickson 2007-09-15 17:38:26 UTC
Fixed in ypserv-2.19-6.fc7

Comment 3 Fedora Update System 2007-09-18 22:31:09 UTC
ypserv-2.19-6.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2007-10-29 19:02:53 UTC
ypserv-2.19-6.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.