Bug 24891

Summary: formatting too wide in a2ps-4.13b-7 ?
Product: [Retired] Red Hat Raw Hide Reporter: dunwoody
Component: a2psAssignee: Crutcher Dunnavant <crutcher>
Status: CLOSED WORKSFORME QA Contact: QA Orphan <qa_orphan>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: twaugh
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-04-03 16:55:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description dunwoody 2001-01-24 23:11:12 UTC
I use a2ps to print plain text files from my Raw Hide 20010122 x86 system
via LPRng-3.7.4-3
to a remote LPD print queue.  I use a2ps with no command-line options; e.g.

    a2ps ~/.bashrc

The PostScript generated by a2ps is spooled to a remote LPR print spooler
system running Irix, which then sends the job via Ethernet to a HP LaserJet
5siMX-PS printer with a JetDirect controller.

This setup has worked perfectly with all versions of a2ps up to and
including a2ps-4.13b-3.
When I upgraded from a2ps-4.13b-3 to a2ps-4.13b-7,  a2ps appeared to use a
larger text size,
without changing the number of characters per line (80) before wrapping.

As a result, the formatted output from a2ps expanded
in width to the point that the rightmost part of the output (including the
right-side vertical line)
extended beyond the physical page boundary, resulting in a "cut-off"

I believe that basic PostScript printing is working properly in my
environment.  The PostScript
test page from printtool prints correctly (centered on the page) in this

When I went back to a2ps-4.13b-3 again, everything worked properly again.

This could well be related to some peculiarity of my system configuration
of my local spooling/printing environment, but I decided to file a bug just
in case it really is an a2ps problem.  Further details, if necessary,
available upon request.

Comment 1 Tim Waugh 2001-02-12 18:43:39 UTC
Did you upgrade anything else at the same time that might have had an effect on
this?  LPRng, etc?

Comment 2 dunwoody 2001-02-12 21:39:09 UTC
twaugh@redhat.com writes:
>Did you upgrade anything else at the same time that might have had an effect on
this?  LPRng, etc?

The only variable I'm changing here is the version of a2ps.  I can use rpm -Uv
to switch back and forth
between a2ps-4.13b-3 and a2ps-4.13b-7, and whenever the former is installed, I
get correct behavior;
whenever a2ps-4.13b-7 is installed, I see the problem. 

I have, indeed, upgraded my entire system from Raw Hide 20010122 to Raw Hide
20010131, which includes an upgrade to LPRng-3.7.4-3 to LPRng-3.7.4-6, since I
the original bug report.  I'm still seeing the
same behavior with a2ps-4.13b-3 and a2ps-4.13b-7 -- the former works, the latter

Of course, I don't think that necessarily means that a2ps-4.13b-7 is "broken";
perhaps it's just that there
is some default setting that changed, and I need to research it to find out what
to set it to.  It has been
nice, however, to get correct output without needing to set any parameters.

Comment 3 Crutcher Dunnavant 2001-04-03 16:55:00 UTC
Does this continue to happen with the current rawhide?

I believe you are seeing a2ps trying to use A4 paper. There is some changes to
make it be 'smart' about this now. Try mucking with a2ps's --medium option,
using things like:

	a2ps --medium=Letter

Comment 4 dunwoody 2001-04-04 18:02:12 UTC
I just tried a2ps-4.13b-13.i386.rpm on my Raw Hide 20010310 system, and
the problem I was seeing seems to have gone away.  It now seems
to work like it used to; I did not need to use the --medium option
to get it to work correctly. Thanks for the help!