Bug 251094

Summary: D-Link DSB-R100 drivers missing from 2.6.22.1-41
Product: [Fedora] Fedora Reporter: Jarrod Hyder <jhyder79>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 7   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: 2.6.22.5-76.fc7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-09-14 17:07:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jarrod Hyder 2007-08-07 03:47:56 UTC
Description of problem:
D-Link DSB-R100 radio drivers missing from kernel 2.6.22.1-41 even though they
were present in 2.6.21-1.3194

Version-Release number of selected component (if applicable):
2.6.22.1-41

How reproducible:
N/A

Steps to Reproduce:
N/A
  
Actual results:
Plugin DSB-R100 usb radio and it is not detected.

Expected results:
Plugin DSB-R100 usb radio and it should be visible to KRadio.

Additional info:

Comment 1 Chuck Ebbert 2007-08-10 21:53:42 UTC
What driver loads for that device?
Are there any kernel messages when the device gets plugged in?


Comment 2 Jarrod Hyder 2007-08-14 00:47:50 UTC
As far as I can tell, there are no drivers loaded.

Here is the output from the kernel:
Aug 13 20:45:06 localhost kernel: usb 4-2: USB disconnect, address 4
Aug 13 20:45:09 localhost kernel: usb 4-2: new low speed USB device using 
uhci_hcd and address 5
Aug 13 20:45:09 localhost kernel: usb 4-2: configuration #1 chosen from 1 
choice

Comment 3 Pete Zaitcev 2007-08-14 01:37:43 UTC
Chuck meant to ask what drivers used to drive the device.
Please give us /proc/bus/usb/devices. I have no clue what
driver may be missing. I cannot guess based on the marketing name
(DSB-R100). We certainly didn't kill any on purpose.

Comment 4 Jarrod Hyder 2007-08-14 11:00:51 UTC
Sorry, I misunderstood the question...

The driver that should load is in kernel/drivers/media/radio/dsbr100.ko


Comment 5 Pete Zaitcev 2007-08-14 17:16:36 UTC
I see... No, wait, I don't.

[zaitcev@niphredil F-7]$ grep CONFIG_USB_DSBR configs/*
configs/config-generic:CONFIG_USB_DSBR=m
[zaitcev@niphredil F-7]$ grep VIDEO_V4L2 configs/*
configs/config-generic:CONFIG_VIDEO_V4L2=y
[zaitcev@niphredil F-7]$ 

Looks like a bug somewhere, it should be building fine.


Comment 6 Pete Zaitcev 2007-08-14 17:31:56 UTC
Oh, I see now:

configs/config-generic:# CONFIG_RADIO_ADAPTERS is not set

This was added by:

revision 1.326
date: 2007/07/10 16:15:02;  author: davej;  state: Exp;  lines: +197 -151
* Tue Jul 10 2007 Dave Jones <davej@redhat.com>
- Rebase to 2.6.22

Let's ask Chuck or Dave to set it to =m, I don't think I have access to
Fedora kernels. I won't mess with them without their permission either.


Comment 7 Chuck Ebbert 2007-08-14 17:58:52 UTC
Set =y in FC6, F7 and devel.