Bug 251194

Summary: Deselecting GDM causes no *DM or First Boot to come up when KDM is installed
Product: [Fedora] Fedora Reporter: chris desjardins <cddesjardins>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 7CC: rstrode
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-08-07 19:13:47 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description chris desjardins 2007-08-07 18:26:34 UTC
Description of problem:
Deselecting GDM during DVD installation causes First Boot to not run and 
instead drops to login prompt.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Deselect GDM during installationg
  
Actual results:
Drops to login screen (i.e. no X)

Expected results:
I have KDE installed (and thus KDM) as I selected it during installation.  I 
would have expected KDM to boot up instead of GDM without issue.  The running 
of this wizard should not depend on whether or not GDM is installed.    

Additional info:

Comment 1 Ray Strode [halfline] 2007-08-07 18:34:54 UTC
So what's probably happening is you're ending up in runlevel 3.

Can you attach your /etc/inittab ?

Comment 2 Chris Lumens 2007-08-07 18:45:21 UTC
This is expected behavior, as we only set the default runlevel to 5 if gdm is
installed.  So the question here is whether we should change that check to be
more permissive.

Comment 3 Chris Lumens 2007-08-07 19:13:47 UTC
This will be fixed in the next build of anaconda.