Bug 2540

Summary: Hard disk upgrade does not work
Product: [Retired] Red Hat Linux Reporter: otto
Component: installerAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-05-04 19:22:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description otto 1999-05-04 13:56:43 UTC
I have seen this also on the mailing list, but with no
answer: the hard disk upgrade hangs when rebuilding the rpm
database; it says something about not being able to create a
symlink to a partition that had already been mounted.

If it matters, the files were on /usr/local/redhat, with
/usr under a separate partition, and I tried to give both
local/redhat and /local/redhat as paths. I tried with /var
as a separate partition and as part of /

If you are interested, I can retest and give you all the
details.


BTW The installer *really* doesn't like finding an
unformatted ext2 partition: I admit it's not common to add a
partition while upgrading the OS, but I never felt like
breaking the uptime record just for adding some space...

Comment 1 Bill Nottingham 1999-05-04 19:22:59 UTC
*** This bug has been marked as a duplicate of 2504 ***