Bug 27136

Summary: can't print on A4 paper
Product: [Retired] Red Hat Linux Reporter: Tim Waugh <twaugh>
Component: LPRngAssignee: Crutcher Dunnavant <crutcher>
Status: CLOSED DUPLICATE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.1CC: saint, twaugh
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-02-17 22:34:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
/var/spool/lpd/lp/status.lp
none
printcap
none
printconf.switchboard.adl
none
status.norm from /var/spool/lpd/norm/ none

Description Tim Waugh 2001-02-12 12:52:30 UTC
$ echo hello | mpage -1 -bA4 -o | lpr
$

Nothing is printed.

<?xml version="1.0"?>
<adm_context VERSION="0">
  <id NAME="local" SERIAL="981923872">
    <null/>
    <null/>
    </id>
  <datatree>
    <printconf TYPE="LIST">
      <print_queues TYPE="LIST">
        <letters ATOMIC="TRUE" TYPE="LIST">
          <alias_list ANONYMOUS="TRUE" TYPE="LIST">
            </alias_list>
          <queue_type TYPE="STRING" VALUE="LOCAL"/>
          <filter_type TYPE="STRING" VALUE="MAGICFILTER"/>
          <queue_data TYPE="LIST">
            <printer_device TYPE="STRING" VALUE="/dev/lp0"/>
            </queue_data>
          <filter_data TYPE="LIST">
            <mf_type TYPE="STRING" VALUE="MFOMATIC"/>
            <gs_driver TYPE="STRING" VALUE="bj200"/>
            <printer_id TYPE="INT" VALUE="58720"/>
            </filter_data>
          </letters>
        <pictures ATOMIC="TRUE" TYPE="LIST">
          <alias_list ANONYMOUS="TRUE" TYPE="LIST">
            </alias_list>
          <queue_type TYPE="STRING" VALUE="LOCAL"/>
          <filter_type TYPE="STRING" VALUE="NONE"/>
          <queue_data TYPE="LIST">
            <printer_device TYPE="STRING" VALUE="/dev/lp2"/>
            </queue_data>
          <filter_data TYPE="LIST">
            </filter_data>
          </pictures>
        </print_queues>
      </printconf>
    </datatree>
  </adm_context>

Comment 1 Glen Foster 2001-02-12 23:01:12 UTC
This defect is considered MUST-FIX for Florence Release-Candidate #1

Comment 2 Crutcher Dunnavant 2001-02-13 10:21:46 UTC
Is 'nothing' printed, or do you get a blank page?

Comment 3 Tim Waugh 2001-02-13 10:30:58 UTC
Just try it.

I don't think it even gets as far as printing nothing---there are errors in the
status file.


Comment 4 Tim Waugh 2001-02-13 13:27:20 UTC
You don't even need a printer to do this.  I'll attach the status.lp file.

Comment 5 Tim Waugh 2001-02-13 13:27:57 UTC
Created attachment 9900 [details]
/var/spool/lpd/lp/status.lp

Comment 6 Tim Waugh 2001-02-13 13:32:28 UTC
Oh, wait, I see the problem now.  Why is it prepending '<</PageSize[612
792]/ImagingBBox null>>setpagedevice'?  That seems to be bogus.

Adding that line in after %%BeginProlog makes the page entirely empty, which is
what this will be.

This probably also explains why I've been having trouble with the top margin of
print jobs.

Comment 7 Tim Waugh 2001-02-14 01:37:48 UTC
See also bug 27116.

Comment 8 David Sainty 2001-02-17 22:28:14 UTC
Okay... tried to recreate the scenario Tim had above....

I used printconf-0.1-13, printconf-gui-0.1-13, mpage-2.5.1-5, LPRng-3.7.4-16.

I did:

 $ echo hello | mpage -1 -bA4 -o | lpr

and I got output. Printer is a Xerox DocuPrint N40, configured as a DocuPrint
N32...  I will attach the switchboard xml, printcap and status.<printername>
files now.


Comment 9 David Sainty 2001-02-17 22:32:51 UTC
Created attachment 10340 [details]
printcap

Comment 10 David Sainty 2001-02-17 22:33:37 UTC
Created attachment 10341 [details]
printconf.switchboard.adl

Comment 11 David Sainty 2001-02-17 22:34:40 UTC
Created attachment 10342 [details]
status.norm from /var/spool/lpd/norm/

Comment 12 Crutcher Dunnavant 2001-02-20 05:10:20 UTC

*** This bug has been marked as a duplicate of 27116 ***