Bug 29947

Summary: module e100 does not compile with kernel-source-2.2.17-14
Product: [Retired] Red Hat Linux Reporter: Marius ILIOAEA <mariusi>
Component: kernelAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED ERRATA QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-02-28 17:32:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Marius ILIOAEA 2001-02-28 01:10:21 UTC
Problem: After upgradind to kernel-souce-2.2.17.14 from the RedHat 
Network, module
   "EtherExpressPro/100 support (Intel driver)" (module e100)
wouldn't compile any more.

Cause: The cause is the missing of the necesary lines from from
   /usr/src/linux-2.2.17/drivers/drivers/net/Makefile

Solution: You can copy-paste the missing lines from the Makefile from the 
kernel-source-2.2.16 (included in distribution) or use the diff below:

651a652,655
> ifeq ($(CONFIG_E100),m)
>   M_OBJS += e100.o
> endif
> 
1414a1419,1420
> e100.o: e100.c e100.h
> 	$(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(INCLUDE) -DEXPORT_SYMTAB -c -o 
$*.o $<
! there is a tab and not spaces at the beginning of last line ! 

Note: the regular public (non RedHat) 2.2.18 kernel does not contain this 
module.

Comment 1 Bill Nottingham 2001-02-28 17:32:48 UTC
*** Bug 29949 has been marked as a duplicate of this bug. ***