Bug 3033

Summary: quota tools go into "uninterruptible sleep" during disk operations
Product: [Retired] Red Hat Linux Reporter: torsten.naumann
Component: kernelAssignee: Cristian Gafton <gafton>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.0CC: alan, chris, torsten.naumann
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description torsten.naumann 1999-05-25 10:30:40 UTC
If I do "cp somewhta somewhere" an at the same time I run
repquota and/or quotacheck the quota tools go into sate "D"
(uninterruptible  sleep).

I've tried it on variuos hardware platforms (i386 with
different scsi and ide adaptors).

On the kernel-list comes a patch for 2.2.6 that solves this
problem but it isn't official. Here is the header of this
posting:

List:     linux-kernel
Subject:  Re: sync problem in 2.2.5
From:     Jan Kara <jack@atrey.karlin.mff.cuni.cz>
Date:     1999-04-20 22:15:58

It occurs in RedHat Linux 5.2 and 6.0.

In the official Debian 2.1 Linux Dist. this error occurs
not.

Comment 1 Alan Cox 1999-06-12 16:40:59 UTC
The patch is mostly good. Jan has posted a couple of other updates
since. It doesn't fix the SMP case apparently.

Comment 2 Jay Turner 1999-06-28 15:36:59 UTC
This issue has been forwarded to a developer for further action.

Comment 3 Jeff Johnson 1999-08-31 17:34:59 UTC
Christian, this problem is not fixed in kernel-2.2.12-3.