Bug 30816

Summary: swap partitions not creating extended scheme
Product: [Retired] Red Hat Linux Reporter: John A. Hull <john_hull>
Component: anacondaAssignee: Michael Fulbright <msf>
Status: CLOSED RAWHIDE QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-03-09 23:21:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description John A. Hull 2001-03-06 16:02:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0; DigExt)


Setting up swap partitions in rc2 does not create an extended partition at 
sda5, it will only go to sda4.
A linux native partition must be put in to force an extended partitioning 
scheme on that drive. 

Reproducible: Always
Steps to Reproduce:
1. add 3 swap partitions on one drive
2. the fourth will not go into extended mode, it will be primary
3. no more partitions can be made
	

Actual Results:  No more partitions could be made

Expected Results:  Ability to make more partitions

Comment 1 Glen Foster 2001-03-06 21:14:05 UTC
We (Red Hat) should really try to fix this before next release.

Comment 2 Michael Fulbright 2001-03-07 23:28:02 UTC
Brent please verify this behavior.

Comment 3 Brent Fox 2001-03-08 16:12:23 UTC
Verified this behavior.  Thanks for your report.

Comment 4 Michael Fulbright 2001-03-09 23:21:05 UTC
Fixed in internal tree.