Bug 34952

Summary: up2date agent reports invalid Architecture and OS release Combination
Product: Red Hat Enterprise Linux 4 Reporter: David Lamm <dlamm>
Component: up2dateAssignee: Adrian Likins <alikins>
Status: CLOSED CURRENTRELEASE QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.0CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-04-18 19:30:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description David Lamm 2001-04-06 03:18:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-0.1.28 i586)


Hardware:
 Tyan Trinity ATX  Model S1598
 VIA chipset, K6-2 500 MHz

This seems similar to bug 28990, but I decided to submit a new bug since
this is from the Wolverine Beta release.

"UP2DATE-2.4.4-1"   reports an "Invalid Architecture and OS release
Combination" and "INFO  Release 7.0.91 on i586".

I have included the output of "rpm -qi redhat-release" below as in bug
28990.

Reproducible: Always
Steps to Reproduce:
1.Run up2date agent 2.4.4-1
2.
3.
	

Name        : redhat-release               Relocations: (not relocateable)
Version     : 7.0.91                            Vendor: Red Hat, Inc.
Release     : 1                             Build Date: Sat 17 Feb 2001
02:20:49 PM EST
Install date: Fri 23 Mar 2001 11:44:53 AM EST      Build Host:
porkchop.redhat.com
Group       : System Environment/Base       Source RPM:
redhat-release-7.0.91-1.src.rpm
Size        : 41                               License: GPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : Red Hat Linux release file
Description :
Red Hat Linux release file

Comment 1 Preston Brown 2001-04-06 17:52:07 UTC
guys, are you supporting i586 on the server side?

Comment 2 David Lamm 2001-04-11 05:42:09 UTC
I'm not sure if this helps, but the earlier versions of "up2date", the ones that
allowed anonymous updates, work.  I can actually use them today to get the new
"packages" from the server.
I could use one of these, but I'd much rather use the newer ones, which provide
the "-p  profile" updates.

Comment 3 David Lamm 2001-04-17 20:08:03 UTC
Installed 7.1 last night and the problem still exists!

Comment 4 David Lamm 2001-04-18 19:29:59 UTC
Woo-Hoo, the problem is fixed!!  Was able to use Up2date today without any errors.

You may not hear this often enough, but thanks for all the hard work you guys
put into making Redhat the best Linux distro out there!  I know some people can
get a little snippy, including myself, but you guys are doing a great job!

Thanks again,

Dave

Comment 5 Jay Turner 2001-04-19 11:10:27 UTC
Great!  Closing out this issue then.