Bug 38891

Summary: /sbin/pam_console_apply called before /usr is mounted
Product: [Retired] Red Hat Raw Hide Reporter: Enrico Scholz <rh-bugzilla>
Component: pamAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED CURRENTRELEASE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: nalin
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: pam-0.75 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-09-13 15:07:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Enrico Scholz 2001-05-03 08:57:13 UTC
[perhaps this is a pam-issue...]

/sbin/pam_console_apply is linked against glib:

--------------------
$ ldd /sbin/pam_console_apply 
        libglib-1.2.so.0 => /usr/lib/libglib-1.2.so.0 (0x40027000)
        libc.so.6 => /lib/i686/libc.so.6 (0x4004c000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
---------------------

Because /usr is NFS-mounted at my system, /usr/lib/libglib is not available
in early init-stages. But /sbin/pam_console_appy is called by
/etc/rc.d/rc.sysinit before the netfs-scripts.

So I get at boot an error-messages saying that the libglib library is
missing.

Comment 1 Bill Nottingham 2001-05-03 15:54:14 UTC
Nalin: you want to statically link it against glib?

Comment 2 Tomas Mraz 2005-09-13 15:07:14 UTC
This is already fixed for a long time.