Bug 39964

Summary: Xircom Cardbus modem :: spurious packet receives and error message in /var/log/messages
Product: [Retired] Red Hat Linux Reporter: Need Real Name <avijit>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED NOTABUG QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.1CC: avijit
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-05-09 22:53:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Need Real Name 2001-05-09 22:53:35 UTC
Description of Problem:
 Clean install of rh7.1 on Dell 5000e w/ Xircom Cardbus 10/100:56k The 
system seems to randomly give a 200kb/s rx transfer in /proc/net/dev w/out 
any discernable connection (netstat). It seems to go away on its own as well. The 
other issue to note is that on boot up the cardmgr gives the following error 
message

May  7 02:32:23 bloosqr cardmgr[569]: + don't know how to make device 
"xircom_cb"

May  7 02:32:23 bloosqr cardmgr[569]: + /dev/xircom_cb: No such file or 
directory
Perhaps I just have to mknod a certain type of device to fix the problem?



How Reproducible:

   The spurious receives are not reproducible in any sense of the word. The error 
message is always reproducible :)
Steps to Reproduce:
1. Boot w/ Xircom Card in :)
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Arjan van de Ven 2001-05-10 08:17:02 UTC
The driver puts the card in "receive all" mode. There's nothing that can be 
done at that, it seems the card is either "receive all packets" or "receive no
packets", the "receive only my packets" mode is defective.

The cardmgr messages are weird but it looks like an interaction with cardmgr
and the hotplug system. The message is harmless.... cardmgr isn't involved for
cardbus cards.