Bug 405401

Summary: chkconfig assign incorrect priorities to services init scripts in /etc/rc?.d
Product: [Fedora] Fedora Reporter: Igor A Tarasov <linux>
Component: chkconfigAssignee: Bill Nottingham <notting>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: low    
Version: 8CC: rvokal, sarcastic.mannequin
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-11-30 12:21:24 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 372101    
Bug Blocks:    

Description Igor A Tarasov 2007-11-30 00:20:45 EST
[root@linux rc5.d]# rpm -q chkconfig
chkconfig-1.3.36-1

BEFORE using chkconfig:

[root@linux rc5.d]# head /etc/init.d/messagebus
#!/bin/sh
#
# messagebus:   The D-BUS systemwide message bus
#
# chkconfig: 345 22 85

[root@linux rc5.d]# ls -1 /etc/rc5.d/*messagebus*
/etc/rc5.d/S22messagebus

And service start in expected order 22 as specified in init script header.

AFTER using chkconfig:

[root@linux rc5.d]# chkconfig messagebus off
[root@linux rc5.d]# ls -1 /etc/rc5.d/*messagebus*
/etc/rc5.d/K00messagebus

[root@linux rc5.d]# chkconfig messagebus on
[root@linux rc5.d]# ls -1 /etc/rc5.d/*messagebus*
/etc/rc5.d/S99messagebus

Now, service start at last order 99 !!! And after using chkconfig or 
system-config-services ALL services change start order to 99 !!!
All my system become to broken and unusable state, because some services can't 
start before other start. For example haldaemon wan't start before messagebus 
and sendmail don't start before named and so on...

Workaround: manually adjust symlinks in /etc/rc?.d to right name.
Comment 1 Bill Nottingham 2007-11-30 11:24:52 EST
It's applying the LSB dependencies.

dbus requires: $syslog $local_fs

What do you have that provides those, and what do they require, etc?
Comment 2 Igor A Tarasov 2007-11-30 12:21:24 EST
dbus provides: messagebus, requires: $syslog $local_fs
rsyslog: provides $syslog, requires: $local_fs $network $remote_fs
netfs: provides $local_fs $remote_fs
network: provides $network

Sorry, i understand my mistale
I was change netfs init script priorities, that it stop _before_ NetworkManager 
to umount CIFS file system before NetworkManager stop and disconnect WiFi.
Comment 3 Bill Nottingham 2007-12-03 13:21:55 EST
*** Bug 408211 has been marked as a duplicate of this bug. ***