Bug 4077

Summary: passwd does not add password to empty field
Product: [Retired] Red Hat Linux Reporter: mw
Component: passwdAssignee: Cristian Gafton <gafton>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: mw
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-09-20 15:14:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description mw 1999-07-16 18:06:31 UTC
When the password field is empty in /etc/passwd, passwd does
not add the encrypted passwd to the field, and it does not
indicate it with an error.

Here is the complete experiment:

# useradd okidoki
# grep okidoki /etc/passwd
# emacs /etc/passwd         (empty password field)
# grep okidoki /etc/passwd
# passwd okidoki
Changing password for user okidoki
New UNIX password:                     (typed MaciLaci)
Retype new UNIX password:              (MaciLaci)
passwd: all authentication tokens updated successfully
root@moni: ~
# grep okidoki /etc/passwd

How can this be a problem (besides, that I think it is not a
correct behavior) since RH 6.0 does not let you log in w/o
an empty passwd field?

Well, imagine that on a yp server, after emptying the passwd
field, I run passwd (thinking passwd is set), then run

(cd /var/yp; make)

Now, on another older (5.2) RH box on the same NIS domain, I
could log in as okidoki w/o a passwd!  (I ran this
experiment with a 5.2 box as a yp server but passwd-0.58-1
and pwdb-0.58-3 installed).

Let me remark that yppasswd seems to behave correctly, but
linuxconf also gets confused (I guess it is running passwd).

Mate Wierdl

Comment 1 Jay Turner 1999-07-19 14:44:59 UTC
This has been confirmed in the test lab.

Comment 2 Cristian Gafton 1999-09-20 15:14:59 UTC
Should be fixed in the next release.