Bug 41470

Summary: Error transferring install image to hard drive - probably out of disk space
Product: [Retired] Red Hat Linux Reporter: Bill Hegardt <bill>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED CURRENTRELEASE QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.1CC: danbrown, goemon, jason, justshop, nivis
Target Milestone: ---   
Target Release: ---   
Hardware: i586   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-09-30 15:39:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Bill Hegardt 2001-05-20 22:09:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Win95; U)

Description of problem:
During install I receive the message "An error occurred transferring the install image to your hard drive.
You are probably out of disk space." The target PC is a 200Mhz Pentium with Maxtor  4Gb hard disk and
32Mb of RAM (bare minimum - I know). There are no non-Linux partitions on the drive. I  have tried partitioning
manually or automatically with the same results. I am able to install RH 7.0 on this drive successfully using the
same partition table created by the 7.1 aborted install. The target PC has been running RH 7.0 fine from a 2Gb
drive that I removed during the 7.1 install. I use text install due to low RAM. I've tried expert mode install, Workstation or custom
type installs. I'm installing from CDROM with a boot floppy made from rawrite. I've also tried checking for bad
blocks during formatting - same results. When partitioning manually I create a 32Mb /boot partition, a 256Mb swap partition
and use the remaining space for the / partition. The error occurs shortly after it begins transferring files (within 20 seconds).
I don't see how the error could be related to low disk space. No errors occur during formatting or bad block checks
The hard disk did have a previous Win 9x partition on it, but I deleted it and both disk druid and fdisk show no traces of it

How reproducible:

Steps to Reproduce:
1. Make boot floppy
2. Install from CD to a PC with 32Mb RAM and a 4Gb hard drive
3. Use text mode
4. Choose Workstation install
5. Manual or Auto partition

Additional info:

Comment 1 Brent Fox 2001-05-20 23:43:47 UTC
Strange.  Can you send the output of 'fdisk -l /dev/hda' so we can see exactly
how big the / partition is?

Comment 2 Bill Hegardt 2001-05-22 04:26:57 UTC
/tmp/hda 240 heads 63 sectors 558 cyl

         Start  End   Blocks     Id   System
hda1    1       5      37768+    83 Linux
hda2    6       558  4180680   5   Extended
hda5    6       523  3916048+ 83 Linux
hda6   524    558   264568+  82 Linux Swap

The actual drive has 8930 cylinders, 15 heads, and 63 sectors
hda1 is /boot, hda5 is /

I hope this helps.

Comment 3 Brent Fox 2001-05-22 20:07:19 UTC
  What about this...at some point in the install, go to VC2 and go to
/proc/ide/hda.  Can you send the contents of the 'capacity', 'geometry', and
'model' files?

Comment 4 Bill Hegardt 2001-05-23 04:13:37 UTC

physical 8930/15/63
logical 558/240/63

Maxtor 84320D4

I tried an upgrade to 7.1 after installing RH 7.0 successfully on this disk. I got a signal 11 error, so perhaps this problem is due to
a hardware problem that for whatever reason does not show up on 7.0

Comment 5 Need Real Name 2001-05-23 21:48:42 UTC
Hi i have exactly the same problem :
i am going just crazy... guys :

i am trying to install rh 7.1 for god knows what time
and still without success :

the installation gets stacked at the point of :
"transferring install image to harddrive"

and it gives the error
"it was an error, maybe you haven't got enough free space"
or something like that but that's not true:

i have a 14 GB allocated just for linux
512MB  swap
/     7GB
/usr all the rest

i tried all the option available :
disk druid
with all options with those tools

nothing just helps
the system hangs on the point of
"transferring install image to harddrive"

it's driving me nuts....
what the hell i am suppose to do to get it work !!!!?????????

I know that if i turn to Red Hat
god knows when i'll get an answer....

if somebody knows something please help..
i need to install it...

and i don't want to mess with mandrake
mandrake just freezes on my machine...


900mHZ AMD
Chaintech motherboard 7AJA
20GB WD +
30GB Quantum : 14GB for linux

Comment 6 Need Real Name 2001-05-23 21:51:25 UTC
I am sorry for my arrogent tone with the last massage but
that problem just drived me nuts...

Comment 7 Bill Hegardt 2001-05-27 19:24:06 UTC
I just tried installing to an new IBM 46Gb drive rather than the 4Gb Maxtor - same error.

Comment 8 Brent Fox 2001-05-31 18:21:55 UTC
Hmm...do you see any error messages on VC3 or VC4?

Also, try booting the installer with 'linux text expert noprobe ide=nodma'. 
Does that help?

Comment 9 Bill Hegardt 2001-06-02 14:19:30 UTC
That works - thanks!  Disk access is slower w/o DMA as I would expect, but at least it installs and runs.

Comment 10 Brent Fox 2001-06-04 16:02:45 UTC
I think that the problem might stem from your CDROM drive.  Can you attach the
output of 'cat /proc/ide/hdc/model' to the bug report?

Arjan, looks like this is another one for the list.

Comment 11 Bill Hegardt 2001-06-05 14:54:59 UTC
Here's the CDROM model info as reported by RH 7.0

CD-ROM Drive/F5A

Comment 12 Arjan van de Ven 2001-06-06 12:33:18 UTC
"CD-ROM Drive/F5A" is the text in /proc/ide/hdc/model ?
I'll add it to our "don't do DMA on it" list then.
Could you do me another favour and paste  / attach the output of
"lspci" to this bug ? (so we know which IDE controller it is)

Thanks for the information so far!

Comment 13 Bill Hegardt 2001-06-07 03:54:24 UTC
Yes "CD-ROM Drive/F5A" is the text in /proc/ide/hdc/model

Here's the lspci output:
00:00.0 Host bridge: Intel Corporation 430HX - 82439HX TXC [Triton II] (rev 03)
00:07.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II] (rev 01)
00:07.1 IDE interface: Intel Corporation 82371SB PIIX3 IDE [Natoma/Triton II]
00:10.0 Ethernet controller: Lite-On Communications Inc LNE100TX (rev 20)
00:11.0 Ethernet controller: Lite-On Communications Inc LNE100TX (rev 20)
00:12.0 VGA compatible controller: S3 Inc. 86c325 [ViRGE] (rev 06)

Comment 14 Need Real Name 2001-07-12 03:17:17 UTC
Have quite a similar problem installing Linux 5.2 to 7.1 to an old pentium133 
computer with new 30GB Western Digital Hard disk, 40MB memory and Matrox 
Millenium II card.

The installation (server or workstation) stalls anywhere from the formatting 
stage to the copying of the installation image.  The system is quite old and 
probably there is a hardware problem somwhere(LED display reading "HI" on CPU 
box flickers while hard disk is being accessed).  However, the system runs fine 
in windows 98 SE.

How and where do I actually type 'linux expert noprobe ide-nodma' ?


Comment 15 Arjan van de Ven 2001-07-12 08:30:41 UTC
You type it at the very first screen, there were you
can chose between graphical install and text install.
and its "ide=nodma"

Comment 16 Niv Israely 2001-10-26 12:58:49 UTC
I have the same problem as all the other people here,
the image transfer bar hangs after about two thirds. 
unfortuately your solution didn't work for me.

I get the same message , that I don't have enough space,although I do.

This happens, although I have successfuly installed RH 7.0 

At VC4, I get a bunch of messages about my cdrom 
which is a regular ATAPI cdrom, not SCSI or anything...

looks something like that :
cdrom: open failed
EXT2-fs warning: maximal mount count reached, running e2fcsk is recommended
hdb: command error: status=0x51 { DriveReady SeekComplete Error }
hdb: command error: error=0x54
end_request: I/O error, dev 03:40 (hdb). sector 1171788

the details of the hard drive, As you can see:



physical            8894/15/63
logical             8894/15/63

fdisk -l /dev/hdc:
   Device  Boot    Start    End    Blocks    Id   System
/dev/hdc1    *         1     35     16506    83   Linux
/dev/hdc2             36   8894  41855871+    5   Extended
/dev/hdc5             36    590    262206    82   Linux Swap
/dev/hdc6            591   8894   3923608+   83   Linux

As I've probably mentioned, 'linux expert text noprobe ide=nodma'
didn't work for me.

Comment 17 Mike Rubel 2003-11-06 04:06:51 UTC
We had the same problem today using Fedora Core 1 on a new Dell
Inspiron 600m which had just successfully installed RedHat 9 two days
ago with no problems.  Booting to ide=nodma solved the problem.

Comment 18 Mace Moneta 2003-11-06 17:59:32 UTC
Yup, just had the problem with Fedora Core 1 upgrading a Redhat 9
release.  This machine (Toshiba 5105-s607 laptop) installed Redhat 8
and 9 with no problem.  Booting with ide=nodma allowed installation to
proceed normally.

Comment 19 Dave Maley 2003-11-07 14:31:43 UTC
Same problem here w/ FC1 and an Asus drive.  Model and lspci info below:

[root@homer root]# lspci
00:00.0 Host bridge: Intel Corp. 82865G/PE/P Processor to I/O
Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corp. 82865G Integrated
Graphics Device (rev 02)
00:1d.0 USB Controller: Intel Corp. 82801EB USB (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801EB USB (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801EB USB (rev 02)
00:1d.3 USB Controller: Intel Corp. 82801EB USB (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801EB USB2 (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corp. 82801EB LPC Interface Controller (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801EB Ultra ATA Storage
Controller (rev 02)00:1f.2 IDE interface: Intel Corp. 82801EB Ultra
ATA Storage Controller (rev 02)00:1f.3 SMBus: Intel Corp. 82801EB
SMBus Controller (rev 02)
01:00.0 Multimedia audio controller: Xilinx Corporation RME Digi96/8
Pad (rev 05)
01:08.0 Ethernet controller: Intel Corp. 82801EB (ICH5) PRO/100 VE
Ethernet Controller (rev 01)
[root@homer root]# cat /proc/ide/hdd/model

Comment 20 Nathan G. Grennan 2003-11-08 01:36:06 UTC
I just ran into this problem with a RH9 to FC1 upgrade on a Intel
D845. ide=nodma works, I think this is going to be wide spread. If it
affects D845 and D865 boards.

Comment 21 Eric Klinger 2003-11-09 09:30:45 UTC
I had the same problem as well - Having been able to install Fedora
Severn .95 fine, I pulled a stick of ram out of the pc (had 1024mb,
pulled 512mb) and that worked for me.  As to whether or not I have a
bad stick?  Who knows, I've installed and ran/running several distros
at the moment and I havent had a problem yet - until Yarrow.  Anyway,
I've put tha ram back in the machine and the pc is running nicely.

Comment 22 Dan Hollis 2003-11-09 10:20:34 UTC
I get the exact same problem installing on a Shuttle SB52G2 XPC with
160gb harddisk.

I thought that 512mb DDR, 1gb swap, and 159gb / is enough to install
Fedora, but the installer seems to think otherwise.

This is a critical, showstopper bug that needs to be fixed asap.

Comment 23 Andriy Rozeluk 2003-11-11 19:38:23 UTC
I ran into this on a Compaq Deskpro P600. Same issue, but it appears
that the "ide=nodma" boot parameter fixed it.

Comment 24 Jason Ish 2003-11-12 08:13:40 UTC
I'm getting this error on a Dell Inspiron 4100 Laptop.  Unfortunately
"ide=nodma" is not helping at all.

I've done fresh installs of Redhat 7.3, 8 and 9 on this laptop with no
issues before.

Comment 25 Jason Ish 2003-11-12 16:02:27 UTC
My laptop had 512M of RAM in it.  By added mem=256M I was able to
install.  I've read about other people with 1GB of RAM that had to set
mem=512M to get it to install which prompted me to test this.

Comment 26 Dan Brown 2004-01-29 03:07:15 UTC
I'm on a Winbook p4 1.7g 512mbRAM laptop, trying to load Fedora Core 1
having the same "Error transferring install image to hard drive,
probably out of disk space" message during the install.  I have tried
the ide=nodma and ide=noprobe with no success.  I'd really like to get
Fedora running. Please advise.

Comment 27 Bugzilla owner 2004-09-30 15:39:01 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/