Bug 42032

Summary: (E100 APM)apm (resume) problem with eepro100 NIC
Product: [Retired] Red Hat Linux Reporter: Inger Karin Haarbye <inger>
Component: kernelAssignee: Jeff Garzik <jgarzik>
Status: CLOSED WONTFIX QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.1CC: peterm, robgerth
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-03-03 08:32:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Inger Karin Haarbye 2001-05-23 20:09:30 UTC
Description of Problem:

After suspend on Dell Inspiron 8000 with buildt in minipci NIC 
(Actiontec) - the NIC doesn't work.
I get lots of these errors all the time: 
wait_for_cmd_done timeout!

How Reproducible:

every time.

Steps to Reproduce:
1. apm -s or suspend in other ways (close the laptop).
2. 
3. 

Additional Information:

Kernel-2.4.2-2 in Seawolf

Comment 1 Arjan van de Ven 2001-05-24 08:28:27 UTC
Some people report that if you change from the "eepro100" to the "e100" module,
suspend works. This change needs to be made in /etc/modules.conf

Could you try this ?

Comment 2 Inger Karin Haarbye 2001-05-25 14:13:58 UTC
No, this didn't work. I tried it before with one of the betas, gave same 
results as eepro100. 
Now I tried it in Seawolf too - I did not get the same error message, but the 
network still doesn't come up after suspend.

/var/log/messages: (free translated from norwegian:)
SIOCSIFFLAGS: resource temporary unavailable
SIOCADDRT: Network is down
SIOCADDRT: Network is noe available.

(Seems like irq-problem maybe - since the driver now has got io-adress, not 
irq)

Comment 3 Rob Gerth 2002-01-03 04:47:21 UTC
I'm experiencing a similar (same?) problem on a T21 Thinkpad. My work around
is to compile eepro100 as a module and to explicitly reload before a network
restart in apmcontinue:
      [ "$NET_RESTART" = "yes" ] && {
           /etc/rc.d/init.d/network stop
           /sbin/rmmod eepro100
           /sbin/modprobe eepro100
           /etc/rc.d/init.d.network start
       }

Comment 4 Jeff Garzik 2004-03-03 05:53:47 UTC
Does e100 driver have the same problem?  We are deprecating eepro100
in favor of e100.


Comment 5 Jeff Garzik 2004-03-03 08:32:46 UTC
Nevermind, closing bug as ancient.