Bug 428547

Summary: Fedora 8 installation on a system with existing NTFS partition causes problems
Product: [Fedora] Fedora Reporter: Jussi Eloranta <eloranta>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED INSUFFICIENT_DATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 8   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-06-04 13:53:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jussi Eloranta 2008-01-13 03:06:46 UTC
Description of problem:

Installation of Fedora 8 on a system with an existing NTFS partition (Mac Pro
with EFI; triple boot Linux/MacOS/Windows XP; this is an intel based system)
modifies the NTFS partition type to "unknown" type (hex C0 - I recall) and
Windows fails to boot after this. I changed the partition type with fdisk back
to NTFS and everything worked again. So, somehow, anaconda changed the partition
type during Linux (Fedolra 8 / 64bit) installation.

I have not tried if this happens on regular BIOS based PCs.

Comment 1 Andy Lindeberg 2008-06-03 17:35:41 UTC
Have you been able to reproduce this error in Fedora 9?

Comment 2 Jussi Eloranta 2008-06-03 20:02:53 UTC
Sorry.. cant' test it any more. I got so frustrated with mac and windows that I
have removed them from my computers.