Bug 429676

Summary: SELinux is preventing the /usr/sbin/semodule from using potentially mislabeled files ().
Product: [Fedora] Fedora Reporter: Valent Turkovic <valent.turkovic>
Component: selinux-policyAssignee: Josef Kubin <jkubin>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 8   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-02-20 13:33:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Valent Turkovic 2008-01-22 12:42:13 UTC
Description of problem:
Summary
    SELinux is preventing the /usr/sbin/semodule from using potentially
    mislabeled files (<Unknown>).

Detailed Description
    SELinux has denied /usr/sbin/semodule access to potentially mislabeled
    file(s) (<Unknown>).  This means that SELinux will not allow
    /usr/sbin/semodule to use these files.  It is common for users to edit files
    in their home directory or tmp directories and then move (mv) them to system
    directories.  The problem is that the files end up with the wrong file
    context which confined applications are not allowed to access.

Allowing Access
    If you want /usr/sbin/semodule to access this files, you need to relabel
    them using restorecon -v <Unknown>.  You might want to relabel the entire
    directory using restorecon -R -v <Unknown>.

Additional Information        

Source Context                system_u:system_r:semanage_t:s0
Target Context                system_u:object_r:unconfined_tmp_t:s0
Target Objects                None [ dir ]
Affected RPM Packages         policycoreutils-2.0.33-3.fc8 [application]
Policy RPM                    selinux-policy-3.0.8-74.fc8
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   plugins.home_tmp_bad_labels
Host Name                     valent.oswireless
Platform                      Linux valent.oswireless 2.6.23.9-85.fc8 #1 SMP Fri
                              Dec 7 15:49:59 EST 2007 i686 i686
Alert Count                   1
First Seen                    Tue 22 Jan 2008 01:30:50 PM CET
Last Seen                     Tue 22 Jan 2008 01:30:50 PM CET
Local ID                      6f43f4f1-8dc1-4e62-97fa-cecf4a0ad97e
Line Numbers                  

Raw Audit Messages            

avc: denied { add_name } for comm=semodule egid=0 euid=0 exe=/usr/sbin/semodule
exit=0 fsgid=0 fsuid=0 gid=0 items=0 name=active pid=28529
scontext=system_u:system_r:semanage_t:s0 sgid=0
subj=system_u:system_r:semanage_t:s0 suid=0 tclass=dir
tcontext=system_u:object_r:unconfined_tmp_t:s0 tty=(none) uid=0



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. start fedora revisor and try to make live cd fased on F8 live cd
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Josef Kubin 2008-02-20 13:33:04 UTC

*** This bug has been marked as a duplicate of 429678 ***