Bug 433612

Summary: Yum does not fails on broken package.
Product: [Fedora] Fedora Reporter: Mohd Izhar Firdaus Ismail <mohd.izhar.firdaus>
Component: xulrunnerAssignee: Gecko Maintainer <gecko-bugs-nobody>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: caillon, dwmw2, ffesti, james.antill, johnp, katzj, pmatilai, stransky, tla
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-02-20 21:21:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Mohd Izhar Firdaus Ismail 2008-02-20 10:58:22 UTC
Description of problem:
I ran yum update just now, when updating xulrunner, it fails during unpacking of
archive. However, instead of failing or notifying the error, yum ended with
"Complete!"

Version-Release number of selected component (if applicable):


How reproducible:
I tried it on Wed, Feb 20. It reproducible all the time even with '--noplugins'
option.

Steps to Reproduce:
1. yum update 
 
Actual results:
[root@hikari izhar]# yum update -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * livna-development: livna.cat.pdx.edu
 * adobe-linux-i386: linuxdownload.adobe.com
 * development: opensource.nchc.org.tw
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package xulrunner.i386 0:1.9-0.beta3.23.nightly20080217.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 xulrunner               i386       1.9-0.beta3.23.nightly20080217.fc9 
development       9.5 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 9.5 M
Downloading Packages:
(1/1): xulrunner-1.9-0.be 100% |=========================| 9.5 MB    01:52     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating  : xulrunner                    ######################### [1/2] 
Error unpacking rpm package xulrunner-1.9-0.beta3.23.nightly20080217.fc9.i386
error: unpacking of archive failed on file
/usr/lib/xulrunner-1.9pre/dictionaries: cpio: rename

Updated: xulrunner.i386 0:1.9-0.beta3.23.nightly20080217.fc9
Complete!


Expected results:
At least say that xulrunner update failed. When there are a lot of updates, the
error my pass without being noticed, and broke other apps that might depend on
the broken package.


Additional info:
I'm not very sure whether this is yum problem or koji generated a broken package.

Comment 1 Seth Vidal 2008-02-20 15:05:13 UTC
the package is changing  dir to a symlink or vice versa - that's the problem.
the second "problem" is that a cpio error is not something that aborts a
transaction.

Fixing the package is what will make a difference. reassigning to xulrunner

Comment 2 Christopher Aillon 2008-02-20 21:21:07 UTC
Except the package doesn't need fixing.  This change was intentional, and it's
unfortunate that rpm simply can't handle it.  This will only affect users of
rawhide, however.

*** This bug has been marked as a duplicate of 433096 ***