Bug 433762

Summary: initscripts do not support MD raid over multipath
Product: Red Hat Enterprise Linux 5 Reporter: Bryn M. Reeves <bmr>
Component: initscriptsAssignee: initscripts Maintenance Team <initscripts-maint-list>
Status: CLOSED WONTFIX QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.1CC: bugzilla-redhat, k.georgiou, rmahique, tao
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-06-12 18:05:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Bryn M. Reeves 2008-02-21 11:47:59 UTC
Description of problem:
In rc.sysinit, MD device activation happens before multipath meaning that if a
user configures an MD array consisting of device-mapper-multipath devices, MD
will bind the devices first and multipath is unable to start correctly.

Working around this requires the user to deactivate MD, run multipath and then
manually reactivate the MD array with the correct (multipathed) member devices.

Version-Release number of selected component (if applicable):
initscripts-8.45.17.EL-1

How reproducible:
100%

Steps to Reproduce:
1. Configure multiple paths to storage using device-mapper-multipath
2. Create an MD software RAID array using the multipath devices (e.g.
/dev/mapper/mpathN).
3. Reboot.
  
Actual results:
Resulting MD array after reboot contains individual paths as members. No
multipath maps are created.

Expected results:
Multipath maps created. MD array contains mpath devices as members.

Additional info:

Comment 1 Bill Nottingham 2008-02-21 18:40:20 UTC
We do not support arbitrary-level stacking of DM and MD - the alternative would
be to keep execing both mdadm and lvm until there's nothing left to do, and I
don't think that's right.

Comment 3 RHEL Product and Program Management 2008-06-02 20:17:36 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Bill Nottingham 2008-06-12 18:05:14 UTC
Yes, at this point we don't do MD on multipath. LVM on multipath should be
supported, if needed.

Comment 6 Bryn M. Reeves 2012-03-27 13:12:00 UTC
*** Bug 704890 has been marked as a duplicate of this bug. ***