Bug 47816

Summary: Installer hangs when loading megaraid module
Product: [Retired] Red Hat Linux Reporter: Jason Watson <jason.watson>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED CURRENTRELEASE QA Contact: Brock Organ <borgan>
Severity: high Docs Contact:
Priority: medium    
Version: 7.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-06-06 14:21:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jason Watson 2001-07-07 20:15:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Tried running install of RH 7.1 on a C440GX+ and a L440GX+ (both running 
dual processor) with a AMI Megaraid 1200 (428) and a Express 200 (466).  
VC4 will show a SCSI timeout error after it tries to scan the channel (or 
in the 428's case, the first channel) for devices.  Installer will refuse 
to continue afterwards.  Worked fine with RH 7.0 and upgrade to kernel 
2.4.5.  Tried text, expert and both boot images from CD and floppy.

How reproducible:

Steps to Reproduce:
1.Run the installer on a L440GX+ or C440GX+ and a Megaraid card
2.Installer will hang on running insmod on the megaraid driver

Actual Results:  Installer hung.  VC4 reported a SCSI timeout error after 
trying to scan the first channel or only channel.

Additional info:

Comment 1 Need Real Name 2001-07-10 20:14:04 UTC
Same bug encountered with AHA274x/284x/294x driver for the AIC-7896/7 Ultra2 
SCSI host adapter. The Install simply hangs when trying to insert the module, 
indicating SCSI timout.

Comment 2 Matt Wilson 2001-07-10 21:16:33 UTC
looks like kernel apic bug

Comment 3 Arjan van de Ven 2001-07-10 21:24:42 UTC
Please try booting with "noapic" on the syslinux prompt; that might just help.