Bug 47901

Summary: missing files from package
Product: [Retired] Red Hat Linux Reporter: Need Real Name <danielsnj>
Component: unixODBCAssignee: Trond Eivind Glomsrxd <teg>
Status: CLOSED NOTABUG QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-07-09 01:28:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Need Real Name 2001-07-08 23:20:58 UTC
Description of Problem: ODBCConfig and DataManager are missing from the 
unixODBC package.


How Reproducible:  Tried packages on RH7.0 and 7.1 as well as downloaded 
package from unixodbc.com ... all packages were missing these key files.


Steps to Reproduce:
1. Install unixODBC
2. try SYMLINKS in SYSTEM menu...all will fail
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Trond Eivind Glomsrxd 2001-07-09 01:28:10 UTC
Which desktop environment?

Comment 2 Trond Eivind Glomsrxd 2001-07-09 01:29:22 UTC
Actually, the files you're missing (and the corresponding desktop files) are in
unixODBC-kde.

Comment 3 Need Real Name 2001-07-09 01:49:07 UTC
unixODBC-kde is not included with the RH7.0 instal CD's.  I can safely assume 
that it is not in the RH7.1 CD's either since I installed everything.  I will 
verify the CD's this afternoon as they are at home and I am at work.  Evrn if 
this is the case.  If the unixODBC-1.8.12-2 rpm is not supposed to contain the 
ODBCConfig and DataManager files, then it should also not contain the SYMLINKS 
to them.

The following is an excerpt from unixodbc.com (follow links to rpms):

>As I don't have Qt or KDE libraries installed on my machine, I don't provide 
>KDE version of the Driver Manager and Explorer. Sorry. If you want it, you 
>have to get the SRPM, install it, change the %define on the top of it and 
>build binary packages yourself.

I found it much easier to just download the tarball and 'make install'.

I must admit I'm abit put off of this being rapidly classified as a RESOLVED 
situation.  I still remain a loyal Red Hat user, but spending an entire morning 
trying to find out why ODBCConfig was missing and then trying multiple 
solutions before finally solving the problem myself is not exactly what I call 
a positive experience with RH7.X.

Don't get me wrong.  I really appreciate the rapid response, but I'm sure 
others have/will encounter this in the future when they realize they need to 
support multiple databases.

Comment 4 Trond Eivind Glomsrxd 2001-07-09 02:07:34 UTC
They were not part of Red Hat Linux 7, because KDE was compiled with the old C++
compiler while unixODBC was compiled with the new one.

The KDE subprograms are included with RHL 7, which used KDE 2.1 compiler with
the standard compiler - I just checked, and the subpackage is included with
these programs.

Comment 5 Trond Eivind Glomsrxd 2001-07-09 02:08:20 UTC
Sorry - the above should read "The KDE subprograms are included with RHL 7.1".