Bug 49890

Summary: dvips fails if have \usepackage{mathtime}
Product: [Retired] Red Hat Linux Reporter: Dan Kelley <dan.kelley>
Component: tetexAssignee: Tim Waugh <twaugh>
Status: CLOSED WONTFIX QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-11-08 11:25:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
latex file none

Description Dan Kelley 2001-07-24 20:42:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
The font 'rmtmi.pfb' is missing, even though 'locate' finds several
rmtmi-related font files ... just not this particular one!

How reproducible:
Always

Steps to Reproduce:
1.latex caro
2.dvips caro
3.
	

Actual Results:  [kelley@Intrusion kelley]$ dvips caro
This is dvipsk 5.86 p1.5d Copyright 1996-2001 ASCII
Corp.(www-ptex@ascii.co.jp)
based on dvipsk 5.86 Copyright 1999 Radical Eye Software
(www.radicaleye.com)
' TeX output 2001.07.24:1744' -> caro.ps
<texc.pro><8r.enc><texps.pro>. <rmtmi.pfb>This is DVIPS, t1part module 
rmtmi.pfb: No such file or directory


Expected Results:  Should create a PostScript file.

Additional info:

Test file "caro.tex" follows:

\documentclass{article}
\usepackage{times}
\usepackage{mathtime}
\begin{document}
Hi $\alpha$ there.
\end{document}

Comment 1 Dan Kelley 2001-07-24 20:44:01 UTC
Created attachment 24827 [details]
latex file

Comment 2 Tim Waugh 2001-08-03 15:13:48 UTC
Do you know when this last worked?

Comment 3 Dan Kelley 2001-08-03 17:06:21 UTC
Hello.  I don't when/if it worked last, actually.  I'm pretty sure I've made 
this work in the past, but I'm not sure if was on my intel machine [on which 
I've had pretty much each of the RH versions, over time] or on a solaris box 
that I used before switching to RH.

Since it's such a simple test-case, one might hope for help from some of the 
Tex/LaTeX discussion groups, but I figured that you folks at RH would have a 
special interest in getting this to work, since having a solid LaTeX, 
combining all the various components, is something that one disto can offer 
over another.  [Note: the test works perfectly in my friend's debian box.]

Let me know if I can help.  I did a _lot_ of web surfing to try to find an 
answer, but I didn't turn up much that made sense to me.

Dan.

Comment 4 Tim Waugh 2001-08-03 22:59:46 UTC
Okay, which version of Debian does your friend have?

(If I can compare a working teTeX with a broken one I stand a better chance of
fixing it.)

Comment 5 Dan Kelley 2001-08-07 20:17:34 UTC
Sorry, the person who told me that it worked on debian is taking some time off
and cannot be reached.  (A new baby arrived!).  However, I found the email, and
have pasted the guts of it below.  It _might_ help. If not, I probably can't do
much more investigation on the debian end.  You folks must have a box with
Debian on it, to check for these sorts of issues, right?  :-)

OK, jokes aside, the below is what my friend sent, from a Debian box:

$ latex caro.tex 
This is TeX, Version 3.14159 (Web2C 7.3.1)
(caro.tex
LaTeX2e <1999/12/01> patch level 1
Babel <v3.6Z> and hyphenation patterns for american, french, german, ngerman, n
ohyphenation, loaded.
(/usr/share/texmf/tex/latex/base/article.cls
Document Class: article 1999/09/10 v1.4a Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size10.clo))
(/usr/share/texmf/tex/latex/mathtime/mathtime.sty)
No file caro.aux.
(/usr/share/texmf/tex/latex/mathtime/my1mtt.fd)
(/usr/share/texmf/tex/latex/mathtime/my2mtt.fd)
(/usr/share/texmf/tex/latex/mathtime/my3mtt.fd)
(/usr/share/texmf/tex/latex/base/ts1cmr.fd)
(/usr/share/texmf/tex/latex/psnfss/ot1ptm.fd)
(/usr/share/texmf/tex/latex/psnfss/ts1ptm.fd) [1] (caro.aux) )
Output written on caro.dvi (1 page, 276 bytes).
Transcript written on caro.log.

$ dvips caro
This is dvips(k) 5.86d Copyright 1999 Radical Eye Software (www.radicaleye.com)
' TeX output 2001.07.24:1622' -> caro.ps
<texc.pro><8r.enc><texps.pro>. <rmtmi.pfb>[1] 

$ locate rmtmi.
/usr/share/texmf/fonts/afm/yandy/mathtime/rmtmi.afm
/usr/share/texmf/fonts/tfm/yandy/mathtime/rmtmi.tfm

$ dpkg -S /usr/share/texmf/fonts/afm/yandy/mathtime/rmtmi.afm
tetex-base: /usr/share/texmf/fonts/afm/yandy/mathtime/rmtmi.afm

Comment 6 Tim Waugh 2001-08-08 11:43:40 UTC
Okay, it's a newer dvipsk (5.86d vs 5.86).  Perhaps it's that.

Comment 7 Tim Waugh 2001-11-08 11:25:05 UTC
(I can't even get this to work with TeXLive..)


Comment 8 Tim Waugh 2001-11-10 17:42:05 UTC
A suggested work-around: use

\usepackage{amsfonts}

instead of

\usepackage{mathtime}