Bug 507168

Summary: gimp help-browser crash
Product: [Fedora] Fedora Reporter: Jonathan Kamens <jik>
Component: gimpAssignee: Nils Philippsen <nphilipp>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: nphilipp
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-07-20 10:43:35 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jonathan Kamens 2009-06-21 09:26:01 EDT
With gimp-2.6.6-4.fc12.i586, gimp-help-browser-2.6.6-4.fc12.i586, and everything else current from rawhide as of last night, selected context help from gimp menu and clicked on dodge / burn tool, and help-browser plugin crashed.  See attached bug buddy report.
Comment 1 Nils Philippsen 2009-06-22 09:34:03 EDT
(In reply to comment #0)
> See attached bug buddy report.  

Where?
Comment 2 Nils Philippsen 2009-07-06 06:17:10 EDT
(In reply to comment #1)
> (In reply to comment #0)
> > See attached bug buddy report.  
> 
> Where?  

There is no bug buddy report attached to this bug yet, would you please do so? It may even be that you see the issue described in bug #508301, would you please check if your problem still persists with gimp-2.6.6-6?
Comment 3 Jonathan Kamens 2009-07-06 13:34:25 EDT
I am unable to test whether this problem still exists or reproduce it, because gimp now hangs on startup after printing these errors:

GLib-GObject-WARNING **: specified class size for type `GimpOperationPointFilter' is smaller than the parent type's `GeglOperationPointFilter' class size

(gimp:2808): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gimp:2808): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(gimp:2808): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gimp:2808): GLib-GObject-WARNING **: cannot retrieve class for invalid (unclassed) type `<invalid>'

pstree shows that there are three gimp processes running, a parent and two children, and that all three are hung in a futex call.  I tried moving all of my ~/.gimp* directories out of the way before launching gimp, and it didn't help.

I have gimp-2.6.6-6.fc12.i586, along with all other current packages from today's Rawhide.

Any suggestions?
Comment 4 Nils Philippsen 2009-07-20 07:55:18 EDT
The problem with starting gimp is fixed now, see bug #510209.