Bug 50758

Summary: ifup ppp0 on a machine with a previously existing default route deletes that route and does not replace it when done.
Product: [Retired] Red Hat Linux Reporter: Panic <mdrew>
Component: redhat-config-networkAssignee: Ngo Than <than>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3CC: pknirsch, teg
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-08-02 21:07:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Panic 2001-08-02 21:03:59 UTC
Description of Problem:

This is the same bug as bug# 48994, still present in beta 3.  Essentially,
on a machine with a previously existing default route assigned by DHCP, a
dial-out with DEFROUTE=yes works fine -- except that it deletes the
existing default route and does not put it back when its done, rendering
the other interface pretty much useless when the call is over.

How Reproducible:

Always

Steps to Reproduce:
1. get machine with previously existing DHCP-delivered default route
2. dial out with DEFROUTE=yes set, then ifdown that interface
3. run route -n and notice that the previously existing default route is
gone, and must be added back in by hand (or the interface has to be
restarted, which is easier).

Actual Results:

default route for network interface is deleted and not replaced.

Expected Results:

default route for the network interface should be replaced.

Additional Information:

Comment 1 Glen Foster 2001-08-06 20:48:39 UTC
This really *is* an initscripts problem.

*** This bug has been marked as a duplicate of 48994 ***