Bug 51608

Summary: installer does not display all drives, even though kudzu recognizese them
Product: [Retired] Red Hat Public Beta Reporter: Luis Villa <louie>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED NOTABUG QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: roswell   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-09-27 16:54:25 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Luis Villa 2001-08-12 20:43:55 UTC
Description of Problem:
When I get to the partitioning options screen in the installer, only drive
hdc is shown as an option to partition. This despite the fact that drives
hdb and sda are recognized by kudzu.

How Reproducible:
Completely, on my system.

Steps to Reproduce:
1. Install normally, selecting 'custom install.' 
2. Get warnings about 'unable to align partition properly.'[1] Click to
ignore them.
3. Select 'automatic partitioning'
4. See that only one hard drive is available.

[1] This is because hdc was formatted incorrectly at one point, such that
hda is mounted and not hda1.

Actual Results:
Only one hard drive is available.

Expected Results:
All three hard drives are selectable for formatting/installation.

Additional Information:
As per the recommendation of jeremy katz, I queried kudzu, which reports
(correctly) that three HDs are installed on the system. The drives are also
mountable without messing with modules, etc., so I'm assuming the kernel is
set up correctly. 

P.S. If you don't have friends at RH it'd be hard to know that installer
bugs should be filed under anaconda. I'd recommend creating another product
in the bugzilla named 'installer' with the same owner, QA contact, etc. as
anaconda or better yet renaming the anaconda product 'installer [anaconda]'

Comment 1 Luis Villa 2001-08-13 15:35:13 UTC
Hrm. I'm going to suggest closing the bug; it appears that the problem was that
I clicked 'cancel' instead of 'ignore'. Perhaps that error dialogue should be
re-written to make it more clear what the impact of the two choices will be.

Comment 2 Glen Foster 2001-08-13 19:07:33 UTC
We (Red Hat) should really try to fix this before next release.

Comment 3 Brent Fox 2001-08-15 15:55:00 UTC
There is a component called 'installer'.  It has the same owner and QA contact
as anaconda.

We're in a screen freeze at the moment, we'll have to change this screen in the
future.  Deferring.