Bug 52674

Summary: Anaconda can't see RH CD1 in DVD-ROM drive
Product: [Retired] Red Hat Linux Reporter: Danny Trinh <danny_trinh>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED CURRENTRELEASE QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3CC: afom_m, clay_cooper, dale_kaisner, danny_trinh, dean_oliver, john_hull, joshua_giles, mark_rusk, matt_domsch, michael_e_brown
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-09-07 00:30:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
DVD-ROM error message none

Description Danny Trinh 2001-08-27 21:48:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
When I install Fairfax RC1 on PE6450 + DVD-ROM, I got this error message:
" I could not find a RedHat Linux CDROM in any of your CDROM drives..."

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
2.Install from CD

Actual Results:  I can't install on PE6450 + DVD-ROM drive, by using CD-
ROM installation method.

Expected Results:  Must be able to install on PE6450+DVD-ROM.

Additional info:

I also try to use "linux ide=nodma" at the prompt, but I get the same 
result (doesn't work).

Comment 1 Michael Fulbright 2001-08-27 22:26:00 UTC
Were you able to boot from the disc?

Did you check the md5sum of the disc?

Comment 2 Danny Trinh 2001-08-28 13:42:39 UTC
Yes, the system boots from CDROM. I also use the same disc on the other system 
with CD-ROM drive, and the CD is working fine.

Comment 3 Brent Fox 2001-08-28 18:12:39 UTC
Have you tried making a boot floppy with the boot.img file and booting that way?

Comment 4 Danny Trinh 2001-08-29 14:31:07 UTC
I tried to use boot.img diskette, and the result is the same.

Comment 5 Danny Trinh 2001-08-29 16:45:27 UTC
I also tried on the other PE6450 with minimum configuration (3GB RAM), and I 
got the same result. However, the same DVD-ROM is working on PE2550.

Comment 6 Danny Trinh 2001-08-30 22:03:54 UTC
I tried RH7.1SBE, It works. Fairfax beta 3 --> no.

Comment 7 Jeremy Katz 2001-08-30 22:37:16 UTC
If you do a network install, does the drive work in the post-install environment?

Comment 8 Danny Trinh 2001-08-31 20:00:48 UTC
After network install, I can use DVD-ROM drive to read CD, and DVD disc.
Also, I tried to install RC2, I got no luck either.

Comment 9 Danny Trinh 2001-08-31 20:06:45 UTC
Below is a content of /proc/ide/hda/model


Comment 10 Bill Nottingham 2001-09-04 16:28:32 UTC
Can you send us one of the drives? We don't have any of those here....
Also, try with the 'acpi' flag to the boot kernel.

Comment 11 Bill Nottingham 2001-09-04 16:45:23 UTC
('apic', not 'acpi'. Sorry about that.)

Comment 12 Danny Trinh 2001-09-05 21:59:35 UTC
Passing "apic" doesn't make a difference. Issue was tested on three PE6450 and 
was reproduced on all. 
"linux ide=nodma" is required when using a "SAMSUNG CD-ROM SN-124". 
Installation on PE6450 with "Toshiba XM-7002B" cdrom exits abnormally even 
when "ide=nodma" is passed.

Comment 13 Danny Trinh 2001-09-05 22:21:42 UTC
After install RC2 by using NFS install method. I can use DVD-ROM drive. 
However, there are a bunch of errors message. I will attach /var/log/messages 
to this bug.

Comment 14 Danny Trinh 2001-09-05 22:22:35 UTC
Created attachment 30999 [details]
DVD-ROM error message

Comment 15 Matt Wilson 2001-09-06 00:38:43 UTC
hardware/kernel problem.

Comment 16 Tesfamariam Michael 2001-09-06 14:40:58 UTC
The same issue was reported and closed against Florence, bug # 29089.

Comment 17 Michael K. Johnson 2001-09-06 21:11:58 UTC
The blacklist entry that fixed #29089 is now in the standard kernel and is
of course not backed out for this release; you can see it in the
ideblacklist patch.

We think that in our very latest BOOT kernels we have used a big enough
hammer to fix this problem.

Comment 18 Tesfamariam Michael 2001-09-07 00:30:50 UTC
Testing with boot.img from kernel 2.4.7-7 (from Rawhide) installed fine using 
this DVD. More testing will be done tomorrow.

Comment 19 John A. Hull 2001-09-11 22:23:56 UTC
Works with Gold.