Bug 53264

Summary: Sendmail refuses connections from everywhere except "localhost"
Product: [Retired] Red Hat Linux Reporter: Alan Hoyle <alanh>
Component: sendmailAssignee: Florian La Roche <laroche>
Status: CLOSED NOTABUG QA Contact: David Lawrence <dkl>
Severity: high Docs Contact:
Priority: high    
Version: 7.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-09-05 19:09:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Alan Hoyle 2001-09-05 19:09:14 UTC
Description of Problem:


My machine is named "nelson.oit.unc.edu."  When I run "telnet localhost 25" I get the appropriate "ESMTP" response.  However when I run "telnet nelson.oit.unc.edu 25" I get a "connection refused" error message.  I get the connection refused message when I try this from the local machine or from a remote machine.  The only change I've made to the sendmail configuration from the default is that I've added "nelson.oit.unc.edu" and "nelson" to /etc/mail/local-host-names.  I originally suspected the problem might be related to ipchains or my TCP_wrappers configuration, but that seems not to be the case.  (I've tried stopping ipchains with "/etc/init.d/ipchains stop" but the problem persists.)





My /etc/hosts.allow file reads "sendmail :  ALL"





my /etc/sysconfig/ipchains file reads as follows:


# Firewall configuration written by lokkit


# Manual customization of this file is not recommended.


# Note: ifup-post will punch the current nameservers through the


#       firewall; such entries will *not* be listed here.


:input ACCEPT


:forward ACCEPT


:output ACCEPT


-A input -s 0/0 -d 0/0 25 -p tcp -y -j ACCEPT


-A input -s 0/0 -d 0/0 80 -p tcp -y -j ACCEPT


-A input -s 0/0 -d 0/0 22 -p tcp -y -j ACCEPT


-A input -s 0/0 -d 0/0 -i lo -j ACCEPT


-A input -p tcp -s 0/0 -d 0/0 0:1023 -y -j REJECT


-A input -p tcp -s 0/0 -d 0/0 2049 -y -j REJECT


-A input -p udp -s 0/0 -d 0/0 0:1023 -j REJECT


-A input -p udp -s 0/0 -d 0/0 2049 -j REJECT


-A input -p tcp -s 0/0 -d 0/0 6000:6009 -y -j REJECT


-A input -p tcp -s 0/0 -d 0/0 7100 -y -j REJECT


 





Version-Release number of selected component (if applicable):


Sendmail 8.11.2/8.11.2








How Reproducible:


Every time





Steps to Reproduce:


telnet nelson.oit.unc.edu 25  





Actual Results:



Trying 152.2.22.44...

telnet: Unable to connect to remote host: Connection refused




Expected Results:



220 nelson.oit.unc.edu ESMTP Sendmail 8.11.2/8.11.2; Wed, 5 Sep 2001 15:08:12 -0400




Additional Information:


I need to have this resolved by Friday, September 7 or I will have lost all of the mail that's been sent to my address since Monday, Sept 3.

Comment 1 David Lawrence 2001-09-06 14:26:37 UTC
Have you made any changes to your /etc/sendmail.cf file to allow remote
connections? Red Hat by default ships sendmail to only allow connections from
localhost for security reasons. You can easily fix this by editing a line in 
/etc/mail/sendmail.mc and then recreating your /etc/sendmail.cf file from that.

Example:
In /etc/mail/sendmail.mc change the following line

DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')

to

dnl DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')

The part 'dnl' is the same as comment a line out. After saving the above change
then execute 

m4 /etc/mail/sendmail.mc > /etc/sendmail.cf

Restart sendmail and you should be able to receive mail remotely. Reopen this
bug report if you do not have positive results.