Bug 5463

Summary: Updated 6.0 local boot image fails to load 3c509.o in network config
Product: [Retired] Red Hat Linux Reporter: djohnson
Component: installerAssignee: Jay Turner <jturner>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: djohnson, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-08 14:00:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description djohnson 1999-10-01 03:34:57 UTC
Using the latest install images, I would get an error like
"adapter could not be found anywhere on your system".
Switching consoles, I see "running /bin/insmod /bin/insmod
Note that /bin/insmod appears twice.  This appears to be a
bug, but not the whole problem, because I moved /bin/insmod
under /mnt, then created a shell script that removed the
extra parm and invoked insmod in it's new location, and set
up a link to the script as /bin/insmod, but still no go.
Problem 2 I noticed that /modules is a link pointing to
/tmp/modules, but 3c509.o had not been extracted there.
Instead, it existed as /tmp/3c509.o.
My workaround was to /bin/insmod /tmp/3c509.o, then back up
in the install process to BEFORE the network config,
whereupon it recognized the existence of eth0 & bypassed
attempt to load the module itself, but continued with the
rest of the network config.  I just had to put 3c509.o into
modules.conf myself after the reboot.

------- Additional Comments From   09/30/99 23:37 -------
BTW, at the problem point, ps ax shows install2 running on install

Comment 1 Bill Nottingham 1999-10-01 16:17:59 UTC
If you're using the latest images, did you boot with 'linux supp'?

------- Additional Comments From   10/01/99 14:08 -------
Yes, I did use linux supp.  Furthermore, although I am not set up to
do a network-based install, I also tried booting off the network
install image, and went far enough to determine that it had no
difficulty loading the 3c508.o module, so the problem is unique to the
local install image.  djohnson@ime.net

Comment 2 Jay Turner 2000-02-08 14:00:59 UTC
The local installation media does not have any metwork modules on it at all, so
that would make sense that you were having trouble loading the module.