Bug 550043

Summary: [fix available] OpenOffice.org fails to open embedded OLE objects in Word documents
Product: Red Hat Enterprise Linux 5 Reporter: Olivier Fourdan <ofourdan>
Component: openoffice.orgAssignee: Caolan McNamara <caolanm>
Status: CLOSED NEXTRELEASE QA Contact: desktop-bugs <desktop-bugs>
Severity: high Docs Contact:
Priority: high    
Version: 5.4CC: bmr, cn6uw7d02, cww, jhird, kem, tao
Target Milestone: rcKeywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586393 (view as bug list) Environment:
Last Closed: 2011-08-03 08:28:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 590060, 586393    
Attachments:
Description Flags
an implementation none

Description Olivier Fourdan 2009-12-23 11:39:13 UTC
Description of problem:

After importing a Microsoft Office Word document in OpenOffice.org Writer, if the file contains embedded OLE documents, OpenOffice.org fails to open these documents and displays a "General Error" popup.

Version-Release number of selected component (if applicable):

openoffice.org-2.3
openoffice.org-3.1.1

How reproducible:

Always

Steps to Reproduce:
1. Open with OpenOffice.org Write a Word document containing an embedded Excel sheet, an embedded PDF and an embedded PowerPoint presentation
2. Double-click on each object to open it
  
Actual results:

Microsoft Excel Worksheet: Opens
PDF: Fails with "General Error"
Microsoft Powerpoint Presentation: Fails with "General Error"

Expected results:

All embedded files are opened successfully if the format is supported

Additional info:

- The same embedded objects are reported to open successfully with OpenOffice.org on Windows (not tested)
- The same version of OpenOffice.org seems to give different results depending on the Linux platform used, for example, OpenOffice-3.1.1 on Fedora 11 opens successfully the Powerpoint presentation, but OpenOffice-3.1.1 on Red Hat Enterprise Linux 5 fails to open the same PowerPoint presentation from the same document.
- Our customer also tested OpenOffice.org-3.2 on F12 and reported the same behavior.

Comment 9 Caolan McNamara 2010-01-14 12:02:35 UTC
Created attachment 383662 [details]
an implementation

Comment 10 Caolan McNamara 2010-01-14 12:06:10 UTC
Is the sample document really private ?, I need a sample to demonstrate this upstream and there doesn't seem to be anything in the attachment that couldn't go upstream.

Comment 14 Caolan McNamara 2010-01-14 16:01:35 UTC
issues re internally supported types sometimes working and not depending on platform etc. would also need to be fixed. Non-deterministic use of hash_maps is the problem there.

Comment 17 RHEL Product and Program Management 2010-08-09 18:59:26 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 18 Caolan McNamara 2010-10-05 19:01:07 UTC
Note that this (should) work in RHEL-6

Comment 24 Caolan McNamara 2011-02-03 11:53:46 UTC
:-(, a pity. Still at least the work in now in current versions. Should be available in RHEL-6.

Comment 25 RHEL Product and Program Management 2011-05-31 14:11:56 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.