Bug 55247

Summary: kpackage can't remove packages
Product: [Retired] Red Hat Linux Reporter: Andreas Bennecke <linuxer>
Component: kpackageAssignee: Ngo Than <than>
Status: CLOSED RAWHIDE QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.2CC: cefrodrigues, chuck
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-11-02 04:52:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Patch (against kdeadmin-2.2-8.src.rpm's contents) that fixes the problem. none

Description Andreas Bennecke 2001-10-28 07:47:30 UTC
Description of Problem:
after a clean reinstall of 7.2 the kpackage program refuses to remove 
unwanted packages.

Version-Release number of selected component (if applicable):
kdeadmin-2.2-8

How Reproducible:
always

Steps to Reproduce:
1. become root, start kpackage
2. mark old package (old kernel, which should be removable because a new 
one is installed from RHN)
3. press "Uninstall"

Actual Results:
The uninstalldialog tells me: "rpmdepCheck() failed."

Expected Results:
Package should be removed.

Additional Information:

Comment 1 Need Real Name 2001-10-29 09:55:17 UTC
i get the "rpmdepCheck() failed." when i try to install anything with kpackage
that is happening on my amd at home and pIII + pii at work

gnorpm works.
command line rpm works

Comment 2 Need Real Name 2001-10-29 09:57:57 UTC
oh, i usually bypass that by disabling the dependency check

Comment 3 Need Real Name 2001-10-30 01:34:04 UTC
I get similar results as noted above.  Under 7.1 it worked perfectly.


Comment 4 Need Real Name 2001-10-31 01:49:34 UTC
I downloaded the latest kdepackage  version 2.2.1-afrom the kdewebsite.  I no
longer get the rpmdepcheck error and so far it seems to work.

Comment 5 Carlos Rodrigues 2001-11-02 04:52:54 UTC
Created attachment 36161 [details]
Patch (against kdeadmin-2.2-8.src.rpm's contents) that fixes the problem.

Comment 6 Ngo Than 2001-11-02 20:23:01 UTC
kdeadmin-2.2-10 should fix this problem. Thanks for a patch file.


Comment 7 Need Real Name 2001-11-06 19:55:06 UTC
I tried the kdeadmin-2.2.1-1.i386.rpm rawhide version and that made did not
fix the problem and I can't seem to find the kdeadmin-2.2-10 anywhere on KDE
or at.rpmfind.net.  Could you put the link up please.  Thanks.


Comment 8 Need Real Name 2001-11-06 21:25:44 UTC
I can't seem to figure these patch commands.  What is the command used to 
patch the rpm?  Thanks.


Comment 9 Ngo Than 2001-11-06 22:37:51 UTC
you find it on ftp://people.redhat.com/than/7.2