Bug 56752

Summary: eth0 failed to load at startup under RedHat 7.2
Product: [Retired] Red Hat Linux Reporter: Need Real Name <pineme>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED CURRENTRELEASE QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.2CC: nleahy
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-09-30 15:39:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Need Real Name 2001-11-26 22:51:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 5.0)

Description of problem:
eth0 failed to load at startup under RedHat 7.2. This happened to 2 
different Intel-based servers using either 3C905B and AMD PCInet32. These 
two nics worked fine under previous 7.x RedHat versions

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Rebooted servers
2.Watched startup modules loading and looked for eth0. Eth0 never loaded
3.Check cat /proc/pci
4. 3c905B or PCInet32 present
5. tried insmod to load the net module.
	

Actual Results:  eth0 never loaded either.

Expected Results:  nic module driver should be installed and initialized 
after redhat installation. eth0 should be loaded when system booted up.

Additional info:

If I isntalled Redhat 7.1 using those nics, they will work fine.

Comment 1 Arjan van de Ven 2001-11-27 08:42:55 UTC
The 3c59x driver works for me (my testmachine uses it for net connectivity); is
this by chance a 440GX chipset system ? (If so, please use the smp kernel)

Comment 2 Need Real Name 2001-11-28 01:42:29 UTC
Affected systems were not 440GX chip set types.
Installed Intel Pro 100 NIC. This NIC works fine.

Comment 3 Nicole Leahy 2003-01-21 18:25:33 UTC
I am experiencing this difficulty on my machine as well.  I spend quite a bit of time 
trying to get Xircom ethernet/modem card working before I realized that eth0 never 
appeared on startup.

My system:
Dell Inspiron 7500, 500MHz, 512 MB RAM
dual boot: RedHat 7.2/Windows 98se using lilo
ethernet/modem card:  Xircom CardBus Ethernet 10/100+Modem 56, RBEM56G-100


Comment 4 Bugzilla owner 2004-09-30 15:39:17 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/