Bug 587863

Summary: Cannot deactivate mouse clicks with touchpad
Product: Red Hat Enterprise Linux 6 Reporter: Mathieu Baudier <mbaudier>
Component: control-centerAssignee: Control Center Maintainer <control-center-maint>
Status: CLOSED CURRENTRELEASE QA Contact: desktop-bugs <desktop-bugs>
Severity: medium Docs Contact:
Priority: low    
Version: 6.0CC: bnocera, mclasen, notting, peter.hutterer, tpelka, vbenes
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: control-center-2.28.1-18.el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-15 13:53:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Mathieu Baudier 2010-05-01 07:29:34 UTC
Description of problem:

In GNOME > System > Preferences > Mouse > Touchpad it is not possible to uncheck 'Enable mouse clicks with touchpad'

This is a problem because since it is a MacBook Pro touchpad (with one button) one makes massive use of the multi-finger touch (two fingers for right-click, three finger for middle-click) which often causes a single-click to be performed.

A workaround is to install gconf-editor and go into:
/desktop/gnome/peripherals/touchpad and uncheck tap_to_click
(but it will be checked again if one open the GNOME > System > Preferences > Mouse > Touchpad dialog again)

Version-Release number of selected component (if applicable):

RHEL 6 Beta 20100414

How reproducible:

Always

Steps to Reproduce:
1. Go to GNOME > System > Preferences > Mouse > Touchpad
2. Try to uncheck  'Enable mouse clicks with touchpad'
  
Actual results:

The 'Enable mouse clicks with touchpad' checkbox is not enabled

Expected results:

This behavior should be configurable.

Additional info:

Comment 2 RHEL Product and Program Management 2010-05-01 09:14:58 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Bastien Nocera 2010-05-14 10:17:22 UTC
Peter, didn't we already fix something similar?

Comment 4 Peter Hutterer 2010-05-16 22:17:30 UTC
Yes, GNOME bug 606793. It's a rather trivial fix too.

https://bugzilla.gnome.org/show_bug.cgi?id=606793

Comment 5 Tomas Pelka 2010-05-27 14:26:33 UTC
Reproducer in description, giving qa_ack.

Comment 6 Bastien Nocera 2010-06-01 17:32:48 UTC
Fixed in control-center-2.28.1-18.el6

Comment 7 Tomas Pelka 2010-06-22 13:26:36 UTC
Mathieu,
please could you confirm that this issue is fixed?

No apple hardware available.

Thanks,
Tom

Comment 8 Mathieu Baudier 2010-06-22 13:36:43 UTC
I'd test with pleasure, but where are the update supposed to come from?

Last time I tried yum update on my RHEL 6 Beta, nothing was available.
Or is a RHEL 6 Beta 2 available? (I would probably have been aware of this)

Please note that I am not (yet) a Red Hat customer.

Comment 9 Tomas Pelka 2010-06-22 15:19:37 UTC
(In reply to comment #8)
> I'd test with pleasure, but where are the update supposed to come from?
> 
> Last time I tried yum update on my RHEL 6 Beta, nothing was available.
> Or is a RHEL 6 Beta 2 available? (I would probably have been aware of this)
> 
> Please note that I am not (yet) a Red Hat customer.    

Please be patient, update should be available soon.

Thanks
Cheers,
Tom

Comment 11 Mathieu Baudier 2010-07-02 09:25:03 UTC
I updated my installation from the RHEL 6 Beta 2 Workstation CDROM (fresh install now crashes, I'll book another bug).

The checkbox is still greyed, so I'm afraid that this is not fixed.

Comment 12 Vladimir Benes 2010-09-16 15:05:14 UTC
Mathieu,
any update here? have you installed beta 2? if not could you try create a new user and test it there?

thanks,
Vladimir

Comment 13 Mathieu Baudier 2010-09-16 15:29:34 UTC
I just created a new user but it also has the same problem (checkbox "Enable mouse clicks with touchpad" checked and greyed).

As I said in comment #11, I could not install RHEL 6.0 Beta 2 from scratch because of bug 610510 (marked as duplicate of bug 597925) and I updated my Beta 1 installation using the CDROM as a yum repo.

Unfortunately I cannot afford to wipe the laptop completely since I have quite a few operating systems on it, and I use it on customer sites.
The installation issue was apparently fixed in RHEL6.0-20100701.0 (see Comment 11 of bug 597925), so if I can get access to a later version I'm happy to try a fresh install.

As I put previously, the issue is much more serious that it sounds because it makes multi-touch more or less unusable (this is especially bad on one-button Apple hardware, but I guess these are not really targeted by RHEL...)

Don't hesitate to tell me if I can try something more: the lack of support for this particular touchpad in RHEL/CentOS 5 (I think support for it was included around 2.6.27) is really a pain for me (and forces me to use Ubuntu in parallel).
So, I'm really motivated to have RHEL 6 working properly on this laptop.

Comment 14 Vladimir Benes 2010-09-16 15:53:42 UTC
Sorry, I am afraid we cannot ship out anything newer now. I am looking for a MacBook Pro here to test in-house. Will keep you updated.

Comment 15 Mathieu Baudier 2010-09-16 16:09:15 UTC
Ok, don't hesitate to tell me if I can do anything else without a fresh install (this RHEL 6 Beta install is not used for anything else than testing/reporting)

Probably an OT question but: can a MacBook Pro hardware be officially supported by Red Hat? (I'm considering buying a RHEL Desktop when 6.0 is out...)

Comment 16 Mathieu Baudier 2010-09-17 08:03:09 UTC
I have a good and a bad news:
- the good is that after cleaning up a bit my LVM I could install a fresh RHEL 6 Beta 2
- the bad is that the problem is still there

Comment 17 Tomas Pelka 2010-09-17 08:31:00 UTC
Hey Mathieu,
thank you for your effort, unfortunately there is chance that Vlad will be able to find some MacBook here. Please stay tuned.

Thanks
Tom

Comment 18 releng-rhel@redhat.com 2010-11-15 13:53:00 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.