Bug 590377

Summary: Updating gpsd.i686 0:2.94-1.fc14 failed because of dependency problems
Product: [Fedora] Fedora Reporter: Karsten Roch <karo1170>
Component: kdebase-workspaceAssignee: Ngo Than <than>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: fedora, jreznik, kevin, lorenzo, ltinkl, mathstuf, mlichvar, rdieter, silfreed, smparrish, than
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-10 08:26:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Karsten Roch 2010-05-09 09:42:47 UTC
Description of problem:

Updating  gpsd.i686 0:2.94-1.fc14 failed because of dependency problems with kdebase-workspace.

Version-Release number of selected component (if applicable):

kdebase-workspace-4.4.3-1.fc14.i686
gpsd-2.39-7.fc14.i686
gpsd.i686 0:2.94-1.fc14

How reproducible:

Always.

Steps to Reproduce:

yum update gpsd
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: libgps.so.18 for package: kdebase-workspace-4.4.3-1.fc14.i686
---> Package gpsd.i686 0:2.94-1.fc14 set to be updated
--> Finished Dependency Resolution

Actual results:

Error: Package: kdebase-workspace-4.4.3-1.fc14.i686 (@rawhide)
           Requires: libgps.so.18
           Removing: gpsd-2.39-7.fc14.i686 (@rawhide)
               libgps.so.18
           Updated By: gpsd-2.94-1.fc14.i686 (rawhide)
               Not found
  

Expected results:

successful update of gpsd 

Additional info:

Comment 1 Miroslav Lichvar 2010-05-10 07:20:20 UTC
kdebase-workspace needs to be patched and rebuild with the latest gpsd.

In the meantime, you can try yum --skip-broken.

Comment 2 Kevin Kofler 2010-05-10 08:26:57 UTC
kdebase-workspace has already been rebuilt, your mirror is out of date.