Bug 591581

Summary: Can not install KpackageKit because of dependency problems
Product: [Fedora] Fedora Reporter: Vladimir Jovic <vladimir>
Component: PackageKitAssignee: Richard Hughes <richard>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: extras-orphan, jonathan, kevin, rdieter, richard, smparrish
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-12 15:48:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Vladimir Jovic 2010-05-12 15:41:53 UTC
Description of problem:

I tried to install KPackageKit-qt-devel package, but I couldn't because of dependency problems.



Version-Release number of selected component (if applicable):

PackageKit-qt-0.6.3-1.fc13.i686


How reproducible:

always

Steps to Reproduce:
1. yum install PackageKit-qt-deve
2.
3.
  
Actual results:

[root@playground cyclades]# yum install PackageKit-qt-devel
Loaded plugins: presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package PackageKit-qt-devel.i686 0:0.6.3-1.fc13 set to be updated
--> Processing Dependency: PackageKit-qt = 0.6.3-1.fc13 for package: PackageKit-qt-devel-0.6.3-1.fc13.i686
--> Processing Dependency: libpackagekit-qt.so.14 for package: PackageKit-qt-devel-0.6.3-1.fc13.i686
--> Running transaction check
---> Package PackageKit-qt.i686 0:0.6.3-1.fc13 set to be updated
--> Processing Dependency: PackageKit = 0.6.3-1.fc13 for package: PackageKit-qt-0.6.3-1.fc13.i686
--> Finished Dependency Resolution
Error: Package: PackageKit-qt-0.6.3-1.fc13.i686 (fedora)
           Requires: PackageKit = 0.6.3-1.fc13
           Installed: PackageKit-0.6.4-1.fc13.i686 (installed)
           Available: PackageKit-0.6.3-1.fc13.i686 (fedora)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@playground cyclades]#

Expected results:

the package is installed

Additional info:

I am using fedora 13, with all packages up to date (today is 12th may 2010)

Comment 1 Rex Dieter 2010-05-12 15:48:37 UTC
You have a mixture of updates + updates-testing packages.

hint: f13 prereleases had updates-testing enabled by default, but that was disabled recently in preparation of the final release.

so, either enable updates-testing again, or you'll have to downgrade the currently installed items you have from updates-testing.

Comment 2 Vladimir Jovic 2010-05-12 16:08:09 UTC
(In reply to comment #1)
> You have a mixture of updates + updates-testing packages.
> 
> hint: f13 prereleases had updates-testing enabled by default, but that was
> disabled recently in preparation of the final release.
> 
> so, either enable updates-testing again, or you'll have to downgrade the
> currently installed items you have from updates-testing.    

This is correct. After removing KPackageKit package and installing it again, everything works fine. The installed version is 0.6.3-1