Bug 601025

Summary: beaker's log couldn't prompt enough information to determine where the problem is
Product: [Community] Beaker Reporter: yanfu,wang <yanwang>
Component: beahAssignee: Marian Csontos <mcsontos>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: high    
Version: 0.5CC: bpeck, kbaker, mcsontos, rmancy
Target Milestone: ---Keywords: Regression
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-06-10 15:30:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 598631, 613756, 613768    
Bug Blocks: 593663, 593365    

Description yanfu,wang 2010-06-07 02:57:25 UTC
Description of problem:
I could get obvious problem prompt when run rhts testcase by rhts log, but beaker's log couldn't give me like that.


How reproducible:
always


pls refer to below links:
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=161107&type=Single
I got the error info:
"/distribution/virt/install/install_guest-81-125.rhts.eng.bos.redhat.com_libvirterror "

and could get clear info by check the log, so I search and find it's a bug opened:
http://rhts.redhat.com/testlogs/2010/06/161107/412603/3368079/virt-install.log
"
...
libvirtError: internal error Process exited while reading console log output: char device redirected to /dev/pts/2
qemu: could not open disk image /var/lib/libvirt/images/guest-81-163.rhts.eng.bos.redhat.com: Invalid argument
"


but in beaker, just job abort and no clear info shown where the problem like rhts behaviour:
https://beaker.engineering.redhat.com/jobs/1939


Expected results:
clear error info prompt.

Additional info:

Comment 1 David Kovalsky 2010-06-07 13:00:26 UTC
Seems like a regression. Missing debugging information for test can have a significant impact on QE productivity. 

I suggest to make this a blocker.

Comment 2 Bill Peck 2010-06-07 13:32:44 UTC
I think this is related to having NetworkManager installed.

Right now the kickstarts are different between rhts and beaker.  This will be fixed in the next upgrade.

The point is though, that the logging is working, we are not getting to the actual install of the virt guest because of something going wrong with bringing up the bridge interface.

If someone could log into the system when this is happening it would be useful.

I'll try and debug if I get a chance, but I'm pretty busy. :-)

Comment 3 Marian Csontos 2010-06-07 13:58:45 UTC
I have seen this happening on snapshot6...

See Bug 598631 - shutdown, reboot, halt and C-A-D don't work

Comment 4 Marian Csontos 2010-06-07 14:06:09 UTC
= Workaround =

1. Bug 598631: connect to the machine (console/ssh) and run

    reboot

2. Bug 589904: after reboot run

    pgrep beah-srv || rm -f /var/beah/*.socket && service beah-srv start

This is fixed upstream and will be delivered soon.

-- Marian