Bug 604440

Summary: smb4k missing proper mount requires
Product: [Fedora] Fedora Reporter: Scott Williams <vwfoxguru>
Component: smb4kAssignee: Marcin Garski <mgarski>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 13CC: mgarski
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-06-21 10:53:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Scott Williams 2010-06-15 21:44:49 UTC
Description of problem:

If user simply installs smb4k and does not have cifs-utils installed, the program opens with error message that the following are needed:

mount.cifs
umount.cifs

mount.cifs is provided by the cifs-utils, so this needs to be added by Requires: in the RPM.  umount.cifs does not exist in the Fedora repo, but I did ln -s umount umount.cifs and it works appropriately.  The best fix would be to fix this inane requirement in smb4k. 

Version-Release number of selected component (if applicable):

smb4k-0.10.4-2.fc13

How reproducible:

Every time

Steps to Reproduce:
1. yum install smb4k
2. run smb4k
  
Actual results:

User gets an error message when opening the program and cannot continue.

Expected results:

The package should faithfully handle dependencies needed to run.

Additional info:

Comment 1 Marcin Garski 2010-06-21 10:53:55 UTC

*** This bug has been marked as a duplicate of bug 574904 ***