Bug 605921

Summary: SELinux is preventing /usr/libexec/gdm-session-worker "write" access on .xsession-errors.
Product: [Fedora] Fedora Reporter: John Margaritopoulos <johnmargaritopoulos>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: dwalsh, johnmargaritopoulos, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:53ccb65e005cc2a6a1294827a018a5033339f5a41e4e0f22e910fe9447454f77
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-06-21 10:47:25 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description John Margaritopoulos 2010-06-19 12:21:29 UTC
Summary:

SELinux is preventing /usr/libexec/gdm-session-worker "write" access on
.xsession-errors.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gdm-session-wor. It is not expected that this
access is required by gdm-session-wor and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:default_t:s0
Target Objects                .xsession-errors [ file ]
Source                        gdm-session-wor
Source Path                   /usr/libexec/gdm-session-worker
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdm-2.29.92-6.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.15-4.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.1-24.fc13.i686 #1
                              SMP Tue Mar 30 18:49:12 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Sat 24 Apr 2010 10:41:21 AM EEST
Last Seen                     Sat 24 Apr 2010 10:41:21 AM EEST
Local ID                      bdade0ef-7547-4fbe-8ce2-91bf23073edd
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1272094881.36:25065): avc:  denied  { write } for  pid=1702 comm="gdm-session-wor" name=".xsession-errors" dev=sda3 ino=14213201 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:default_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1272094881.36:25065): arch=40000003 syscall=93 success=yes exit=0 a0=c a1=0 a2=c a3=9924d18 items=0 ppid=1642 pid=1702 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="gdm-session-wor" exe="/usr/libexec/gdm-session-worker" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gdm-session-wor,xdm_t,default_t,file,write
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t default_t:file write;

Comment 1 Miroslav Grepl 2010-06-21 10:47:25 UTC

*** This bug has been marked as a duplicate of bug 605919 ***