Bug 61033

Summary: remove_inode_page NULL dereference
Product: [Retired] Red Hat Linux Reporter: Clay Cooper <clay_cooper>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3CC: afom_m, dale_kaisner, danny_trinh, dean_oliver, gary_lerhaupt, john_hull, joshua_giles, matt_domsch, michael_e_brown, robert_hentosh, rogelio_noriega
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-04-10 20:50:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 61590    
Attachments:
Description Flags
Ksymoops output
none
6450 UP kernel ksymoops output
none
2550 smp kernel ksymoops output
none
4600 bigmem kernel ksymoops output
none
slimmerlot smp kernel ksymoops output
none
Kysmoops output for 6450
none
Ksymoops output for pe500sc
none
Kymoops output from pe500sc w/ 2.4.18-0.10 installed none

Description Clay Cooper 2002-03-12 15:17:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011019
Netscape6/6.2

Description of problem:
On a 6450 running hampton beta2 (2.4.18-0.1bigmem) w/ A10 bios, 5GB ram, 2GB
swap, and Perc3/SC as boot controller.  

Kernel oops while running newburn after 18 hours.

Attached ksymoops output.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install hampton beta2 on a 6450 w/ Perc3/SC boot controller
2.  Run newburn and note kernel oops
3.
	

Actual Results:  Kernel Oops

Expected Results:  No kernel oops

Additional info:

Comment 1 Clay Cooper 2002-03-12 15:18:13 UTC
Created attachment 48284 [details]
Ksymoops output

Comment 2 Clay Cooper 2002-03-13 15:42:34 UTC
Oops reproduced with UP kernel after 7 hours.

Attaching ksymoops output...

Comment 3 Clay Cooper 2002-03-13 15:47:03 UTC
Created attachment 48404 [details]
6450 UP kernel ksymoops output

Comment 4 Clay Cooper 2002-03-13 16:00:59 UTC
Just saw an oops on a pe2550 running hampton beta 2 (2.4.18-0.1smp).

Attaching ksymoops output...

Would you prefer us to separate these kernel oops issues by platform?  Or is
attaching oops from different platforms on the same issue ok?

Comment 5 Clay Cooper 2002-03-13 16:02:24 UTC
Created attachment 48406 [details]
2550 smp kernel ksymoops output

Comment 6 Clay Cooper 2002-03-13 16:03:59 UTC
Just saw an oops on a pe4600 running hampton beta 2 (2.4.18-0.1bigmem).

Attching ksymoops output...


Comment 7 Clay Cooper 2002-03-13 16:04:47 UTC
Created attachment 48407 [details]
4600 bigmem kernel ksymoops output

Comment 8 Matt Domsch 2002-03-13 16:07:34 UTC
Since these are the same oops (the same function dereferences NULL+0x18), just 
reproduced on different platforms, I say keep them together, rename the title 
__remove_inode_page NULL dereference.

Comment 9 Clay Cooper 2002-03-13 22:29:52 UTC
Created attachment 48431 [details]
slimmerlot smp kernel ksymoops output

Comment 10 Clay Cooper 2002-03-22 15:06:00 UTC
6450 kernel oops w/ beta3 (2.4.18-0.4bigmem)
Attaching ksymoops output...

Comment 11 Clay Cooper 2002-03-22 15:07:18 UTC
Created attachment 49684 [details]
Kysmoops output for 6450

Comment 12 Clay Cooper 2002-03-22 15:10:20 UTC
Kernel oops on pe500sc while running newburn w/ beta3 (2.4.18-0.4)
Attaching ksymoops output...

Comment 13 Clay Cooper 2002-03-22 15:11:02 UTC
Created attachment 49685 [details]
Ksymoops output for pe500sc

Comment 14 Michael K. Johnson 2002-03-26 19:20:03 UTC
It will be worth testing this with 2.4.18-0.9 or later.

Comment 15 Clay Cooper 2002-04-02 16:46:53 UTC
Created attachment 51864 [details]
Kymoops output from pe500sc w/ 2.4.18-0.10 installed

Comment 16 Arjan van de Ven 2002-04-03 09:56:34 UTC
Ah ha!
Found it!
Fixed as of 2.4.18-0.14


Comment 17 Clay Cooper 2002-04-08 14:57:11 UTC
No kernel oops after 3 days of newburn on a beetle (pe500sc) with beta4
(2.4.18-0.13)

Comment 18 Arjan van de Ven 2002-04-08 15:02:51 UTC
Please use 2.4.18-0.16 from now on; it's supposed to have stuff fixed :)

Comment 19 Clay Cooper 2002-04-10 20:50:05 UTC
No kernel oops on a 6450 or a 500sc after 24 hours of newburn w/ kernel
2.4.18-0.16smp/up.

Comment 20 Arjan van de Ven 2002-04-11 12:47:48 UTC
Tentatively closing
If it happens after more testing please reopen this bug