Bug 611509

Summary: SELinux is preventing /bin/bash "getattr" access on /usr/sbin/userdel.
Product: [Fedora] Fedora Reporter: mathepic
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:40137dde05acf3a4b8bcf820601cbd45a9b763fc374793cb9fb655a2cedd1c14
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-07-07 08:10:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description mathepic 2010-07-05 12:28:00 UTC
Summary:

SELinux is preventing /bin/bash "getattr" access on /usr/sbin/userdel.

Detailed Description:

SELinux denied access requested by gdm. It is not expected that this access is
required by gdm and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:useradd_exec_t:s0
Target Objects                /usr/sbin/userdel [ file ]
Source                        gdm
Source Path                   /bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bash-4.1.7-1.fc13
Target RPM Packages           shadow-utils-4.1.4.2-7.fc13
Policy RPM                    selinux-policy-3.7.19-28.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.33.5-124.fc13.x86_64 #1 SMP Fri Jun 11
                              09:38:12 UTC 2010 x86_64 x86_64
Alert Count                   18
First Seen                    Sun 04 Jul 2010 10:00:51 PM EDT
Last Seen                     Mon 05 Jul 2010 07:52:54 AM EDT
Local ID                      51dff5ad-9c6a-4403-8d9d-748bb24e50bd
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1278330774.467:94): avc:  denied  { getattr } for  pid=1377 comm="gdm" path="/usr/sbin/userdel" dev=sda3 ino=10924 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:useradd_exec_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1278330774.467:94): arch=c000003e syscall=4 success=no exit=-13 a0=1b5d200 a1=7fff447b5ee0 a2=7fff447b5ee0 a3=12 items=0 ppid=1 pid=1377 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="gdm" exe="/bin/bash" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gdm,xdm_t,useradd_exec_t,file,getattr
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t useradd_exec_t:file getattr;

Comment 1 Miroslav Grepl 2010-07-07 08:10:56 UTC

*** This bug has been marked as a duplicate of bug 611474 ***