Bug 613320

Summary: Anaconda exits abnormally while installing rhel6-beta2
Product: Red Hat Enterprise Linux 6 Reporter: Kashyap Chamarthy <kchamart>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Release Test Team <release-test-team>
Severity: medium Docs Contact:
Priority: low    
Version: 6.0CC: akozumpl
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-07-12 13:32:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
screenshot of anaconda exiting abnormally none

Description Kashyap Chamarthy 2010-07-10 18:57:30 UTC
Description of problem:

RHEL6-beta2 -- RHEL6.0-20100701.3  install(as a kvm guest on F12), fails to install when I select Basic-Server(with gnome-desktop).

Version-Release number of selected component (if applicable):
RHEL6.0-20100701.3

How reproducible:
Every time

Steps to Reproduce:
1. Pick the iso from here(and verify sha256sum to ensure download complete) -- http://download.devel.redhat.com/rel-eng/RHEL6.0-20100701.3/6.0/Server/x86_64/iso/RHEL6.0-20100701.3-Server-x86_64-DVD1.iso
2. Proceed with it as a kvm guest.
3.Now at the anaconda install wizard, select 'Basic-Server'(or 'Desktop') and customize it by adding 'Gnome-Desktop' and a bunch of other softwares
4. Now, proceed with install
  
Actual results:
Anaconda exits abnormally.

'Anaconda died after receiving signal 6.
install exited abnormally [1/1]'

(See attached screenshot)

Expected results:
Install should go ahead smoothly.

Additional info:
Note: If I just select 'Basic-Server' _without_ any customizations and proceed, install completes successfully.

Comment 2 Kashyap Chamarthy 2010-07-10 19:04:50 UTC
Created attachment 430901 [details]
screenshot of anaconda exiting abnormally

Not sure, what I'm missing. I tried multiple times to get the install going with 'Desktop' and other customizations but to no avail.

Comment 3 Chris Lumens 2010-07-11 21:51:15 UTC
How much memory are you giving your guest, and does the install succeed if you bump the memory up by quite a bit?

Comment 4 Kashyap Chamarthy 2010-07-12 05:08:18 UTC
1024MB RAM. I'm trying with 2048MB as we speak, will report back the result.
And, 2 vcpus (on a quad-code machine) .My host has 10G RAM, so plenty available.

Comment 5 Kashyap Chamarthy 2010-07-12 05:39:19 UTC
Not much luck. I tried with both 2048MB and 3072 MB RAM and install still 'exits abnormally'

Comment 7 Ales Kozumplik 2010-07-12 08:51:07 UTC
Hi Kashyap,

can you please attach output of:

cat /sys/module/kvm_intel/parameters/ept

from the host?

Thanks,
Ales

Comment 8 Kashyap Chamarthy 2010-07-12 08:58:23 UTC
On the host:
======================
root@~ $cat /sys/module/kvm_intel/parameters/ept 
N
root@~ $
=======================

Comment 9 Chris Lumens 2010-07-12 13:32:48 UTC
Marking this as a dup of a hidden bug.  The good news is there appears to be an updated kernel package in the works to fix it.

*** This bug has been marked as a duplicate of bug 607650 ***