Bug 616575

Summary: openmpi does not work with non-infinipath hardware
Product: Red Hat Enterprise Linux 6 Reporter: Jay Fenlason <fenlason>
Component: openmpiAssignee: Jay Fenlason <fenlason>
Status: CLOSED CURRENTRELEASE QA Contact: Gurhan Ozen <gozen>
Severity: high Docs Contact:
Priority: high    
Version: 6.0CC: borgan, dgregor, jburke, jfeeney, michael.hagmann, notting, peterm, snagar
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: openmpi-1.4.1-4.3.el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-10 21:16:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jay Fenlason 2010-07-20 20:07:51 UTC
Description of problem:
infinipath support breaks support for non-infinipath hardware.

Version-Release number of selected component (if applicable):
1.4.1-4.2

How reproducible:
always

Steps to Reproduce:
1.attempt to run an openmpi program on non-infinipath hardware.
2.
3.
  
Actual results:
program fails to run

Expected results:
program runs

Additional info:

Comment 2 RHEL Product and Program Management 2010-07-20 20:17:40 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 6 Jay Fenlason 2010-08-31 15:57:48 UTC
On my machines, which only have mlx4 hardware in them, the libraries that include psm support exit when they fail to open /dev/ipath.  Are you running your tests on machines that have ipath hardware that you aren't using?

Comment 7 Gurhan Ozen 2010-08-31 16:46:20 UTC
(In reply to comment #6)
> On my machines, which only have mlx4 hardware in them, the libraries that
> include psm support exit when they fail to open /dev/ipath.  Are you running
> your tests on machines that have ipath hardware that you aren't using?

I have unloaded ib_mthca module and loaded ib_ipath so that only infinipath devices were up and running and ran openmpi. 

I wonder if you didn't have libipathverbs and infinipath-psm packages on ?

Comment 9 releng-rhel@redhat.com 2010-11-10 21:16:32 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.