Bug 621814

Summary: Allow complete RHTS compatibility
Product: [Community] Beaker Reporter: Marian Csontos <mcsontos>
Component: beahAssignee: Marian Csontos <mcsontos>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: high    
Version: 0.5CC: bpeck, dkovalsk, kbaker, mcsontos, psplicha, rmancy
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-10-28 02:02:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 645769    
Bug Blocks: 614974, 621809, 632609    

Description Marian Csontos 2010-08-06 07:48:51 UTC
Problem:

Some tests are stubborn and refuse to run from wrapper, e.g. tcsh test suite. See Bug 598895.

Resolution:

Instead of fighting them individually, provide environment as close as possible to original.

This will also provide a script with all env.variables required by the test.

Comment 1 Marian Csontos 2010-08-06 07:51:49 UTC
Not 598895 but Bug 607994#c3 re: /CoreOS/tcsh/Sanity/upstream

Comment 2 Marian Csontos 2010-10-22 12:54:20 UTC
Also the tcsh test suite is working well with this tweak. See https://beaker.engineering.redhat.com/recipes/49765.

The last run is with compatibility mode. The last but one is without it.

Going on with testing.

Comment 3 Marian Csontos 2010-10-25 13:08:55 UTC
This works and fixed the reported compatibility issues I was aware of.

Comment 5 Marian Csontos 2010-10-26 07:57:21 UTC
FYI, this requires to pass param

  <param name="RHTS_OPTION_COMPATIBLE" value="yes"/>

to tasks to run in compatible mode. Bug 645769 should remove this necessity.