Bug 624287

Summary: xemacs loops on fontifying *.asy
Product: [Fedora] Fedora Reporter: Horst H. von Brand <vonbrand>
Component: xemacsAssignee: Jerry James <loganjerry>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: loganjerry, steve.traylen
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-11 20:27:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
A simple file that gives xemacs fits
none
The included graphs.asy file for Kn.asy (on this one xemacs does work fine)
none
Full backtrace none

Description Horst H. von Brand 2010-08-15 16:33:39 UTC
Created attachment 438841 [details]
A simple file that gives xemacs fits

Description of problem:
Opening even a trivial asymptote source file gets xemacs into a fontitying frenzy.

Version-Release number of selected component (if applicable):
xemacs-21.5.29-13.fc14.x86_64
xemacs-common-21.5.29-13.fc14.x86_64
xemacs-info-21.5.29-13.fc14.noarch
xemacs-packages-base-20100727-1.fc15.noarch
xemacs-packages-extra-20100727-1.fc15.noarch
xemacs-packages-extra-info-20100727-1.fc15.noarch

How reproducible:
Always

Steps to Reproduce:
1. Open attached Kn.asy file
2.
3.
  
Actual results:
Spinner flickers, xemacs is non-responsive. Have to kill it with kill.

Expected results:
Fontify (or whatever) in a few seconds at most.

Additional info:
xemacs -vanilla does work, but doesn't load the asymptote mode (just fundamental). Hardly optimal ;-)

Comment 1 Horst H. von Brand 2010-08-15 16:35:06 UTC
Created attachment 438842 [details]
The included graphs.asy file for Kn.asy (on this one xemacs does work fine)

Comment 2 Jerry James 2010-08-23 19:46:20 UTC
Hmmmm, this is very interesting.  File saving dialogs are messed up for you, and you experience eternal font locking on this asymptote file, but I see neither symptom on an apparently identical installation.  For me, your test file font locks in under a second.

There is something critically different about our installations, and it is apparently killing basic functionality for you.  We have to figure out what that difference is.

Can you please try this for me?  Start xemacs with -vanilla, then in *scratch*:

(require 'asy-mode)
(turn-on-font-lock)

Does that loop?

Comment 3 Horst H. von Brand 2010-08-31 14:22:19 UTC
(require 'asy-mode)
asy-mode
(turn-on-font-lock)
nil

The second "nil" is instantaneous.

Then I tried:

  xemacs -vanilla graphs.asy

Did the above in *scratch* (again very fast), and then in the buffer for graphs.asy I did "M-x asy-mode", which worked fine.

I'll try on another machine later on and report back. This machine has been riding rawhide for some 2 years, probably lots of cruft accumulated in this time. Or it might be some mess with my init stuff... but I can't see anything fishy in there.

Thanks!

Comment 4 Horst H. von Brand 2010-08-31 14:23:59 UTC
Oh, BTW I found out that _all_ X dialogs in xemacs seem to be non-functional (no reaction to mouse clicks at all).

Comment 5 Horst H. von Brand 2010-08-31 14:28:35 UTC
Sorry, should have checked earlier...

I just ran "xemacs images/graphs.asy", and fontification was instantaneous. The xemacs packages installed are still the same as reported, so this has been fixed somewhere else.

Sorry for the noise.

Comment 6 Jerry James 2010-09-01 03:12:33 UTC
Hmmm.  Well, if the problem shows up again, please reopen the bug.

Comment 7 Horst H. von Brand 2010-09-05 17:13:51 UTC
Sorry, tried graphs.asy (which has always worked). Tried again with the above Kn.asy, same freeze as before.

Comment 8 Jerry James 2010-09-09 03:56:21 UTC
I'm not sure where to look next.  It still works for me just fine.  Is there any chance you could "debuginfo-install xemacs", run XEmacs inside GDB, get into the fontification loop, then break into the debugger and get a stack trace?  That might give me a clue as to what is going on.

Or, as I mentioned in your other bug, if you could share any .Xdefaults or .Xresources files you happen to be using, maybe some setting in there is leading to the X dialog problem.  I can't imagine that would cause *this* bug, though.

Comment 9 Horst H. von Brand 2010-09-27 22:22:44 UTC
Created attachment 450052 [details]
Full backtrace

Did as told.

xemacs goes gaga with "Fontifying Kn.asy... (regexps).." in the echo area.

Comment 10 Jerry James 2011-03-11 18:29:13 UTC
Could you try again with the newly released XEmacs package?  It's 21.5.29-15 on FC-13 and FC-14, or 21.5.29-18 on F-15 or Rawhide.  There was a mistake in the spec file that led to -fno-strict-aliasing NOT being added to CFLAGS, which could have resulted in all kinds of subtly wrong compiled code.

Comment 11 Jerry James 2012-01-12 15:13:26 UTC
Horst, have you had a chance to try any of the newer builds?  I am still unable to reproduce this.  The backtrace shows creation of a bignum, so it looks like some counter is heading to infinity.  If we could figure out which counter it is, that could be the clue I need.

Comment 12 Jerry James 2013-02-11 20:27:32 UTC
I still cannot reproduce, and there has been no response from the bug submitter for a very long time, so I am closing this bug.  Please reopen the bug if more information becomes available.