Bug 652345

Summary: capi udev rule doesn't match kernel
Product: [Fedora] Fedora Reporter: Gus Wirth <gwirth79>
Component: isdn4k-utilsAssignee: Ngo Than <than>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 14CC: than
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-03-16 17:11:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Gus Wirth 2010-11-11 17:16:21 UTC
Description of problem:

The udev rule for the CAPI subsystem doesn't match the kernel.

Version-Release number of selected component (if applicable):

isdn4k-utils-3.2-71.fc14.i686
kernel-PAE-2.6.35.6-48.fc14.i686
udev-161-4.fc14.i686

How reproducible:

Start the capi (ISDN) service, either at startup or later

This will produce an error message:

Starting capi4linux: [   31.963659] CAPI 2.0 started up with major 68 (middleware+capifs)
udevd-work[518]: kernel-provided name 'capi' and NAME= 'capi20' disagree, please use SYMLINK+= or change the kernel to provide the proper name

The offending rule is in:

/lib/udevrules.d/40-isdn.rules

and the rule itself:

SUBSYSTEM=="capi", KERNEL=="capi", NAME="capi20", GROUP="dialout"

Comment 1 Ngo Than 2011-03-16 17:11:01 UTC

*** This bug has been marked as a duplicate of bug 598757 ***