Bug 69196

Summary: Cannot Publish Errata
Product: Red Hat Satellite 5 Reporter: Matt Jamison <jamisonm>
Component: ServerAssignee: Adrian Likins <alikins>
Status: CLOSED RAWHIDE QA Contact: Fanny Augustin <fmoquete>
Severity: high Docs Contact:
Priority: high    
Version: unspecifiedCC: alikins, bretm, cturner, gafton, mihai.ibanescu, robin.norwood, taw
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
URL: /network/errata_editor/confirm_publish.pxt
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-07-18 21:39:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Traceback from sat-app.test.redhat.com none

Description Josef Komenda 2002-07-18 20:00:21 UTC
Description of Problem: 500 error on final errata publis confirmation screen.


Version-Release number of selected component (if applicable): see bug 63780


Steps to Reproduce:
1. Create a 7.2 errata on your satellite 
2. Add a package to a custom child channel
3. publish the errata to the channel
4. Confirm publication of errata to channel

Actual Results: 500 error

Expected Results: happy confirmation


Additional Information: log into sat-app.test.redhat.com to confirm
    user: sat-app
    pass: pink4all

Comment 1 Josef Komenda 2002-07-18 20:03:09 UTC
Created attachment 65849 [details]
Traceback from sat-app.test.redhat.com

Comment 2 Robin Norwood 2002-07-18 20:21:11 UTC
Argument "@@rhnproc_port@@" isn't numeric in subroutine entry at
/usr/lib/perl5/5.6.1/i386-linux/Socket.pm line 315.
Use of uninitialized value in subroutine entry at
/usr/lib/perl5/5.6.1/i386-linux/Socket.pm line 315.


Classic case of garbage in, garbage out.  Looks like the value isn't getting
substituted in /etc/rhn/rhn.conf: 

web.rhnproc_server = @@rhnproc_server@@
web.rhnproc_port =   @@rhnproc_port@@

proper values for a satellite server are *proabably* it's hostname ('localhost'
should work) and 12121

Confirmed that this works on sat-app after file is fixed - old file saved on
sat-app as /etc/rhn/rhn.conf.old for comparison.

Comment 3 Josef Komenda 2002-07-18 21:21:18 UTC
Fixed, closing.

Comment 4 Josef Komenda 2002-07-18 21:38:47 UTC
Whoops, not really fixed - over to Adrian to make a fix to the installer to add
the right default values for:

web.rhnproc_server = @@rhnproc_server@@
web.rhnproc_port =   @@rhnproc_port@@

proper values for a satellite server are hostname ('localhost'
should work) and 12121

Comment 5 Josef Komenda 2002-07-19 17:20:30 UTC
Confirmed good in latest version of installer. Closing.