Bug 694552

Summary: Failing to build xserver if systemtap-sdt-devel is installed
Product: Red Hat Enterprise Linux 6 Reporter: Vasiliy Sharapov <vsharapo>
Component: xorg-x11-serverAssignee: Adam Jackson <ajax>
Status: CLOSED ERRATA QA Contact: Desktop QE <desktop-qa-list>
Severity: unspecified Docs Contact:
Priority: high    
Version: 6.0CC: airlied, ajax, mgordon, syeghiay, tpelka, vbenes
Target Milestone: rcKeywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: xorg-x11-server-1.7.7-29.el6 Doc Type: Bug Fix
Doc Text:
No description necessary, internal RH bug.
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-06 14:38:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 506345    
Bug Blocks: 713024    

Description Vasiliy Sharapov 2011-04-07 16:10:41 UTC
Description of problem:
If systemtap-sdt-devel is present on non-solaris systems xorg-x11-server-1.7.7-28.el6 will fail to build

Version-Release number of selected component (if applicable):
xorg-x11-server-1.7.7-28.el6

How reproducible:
100%

Steps to Reproduce:
1. Have systemtap-sdt-devel installed on an x86 machine
2. Try building xorg-x11-server-1.7.7-28.el6
  
Actual results:
connection.c: In function 'AuthAudit':
connection.c:620: error: invalid initializer

Expected results:
No errors.

Additional info:
As I understand this should have been fixed in -28 first and backported to -26 but didn't. If someone other than airlied is fixing this they can just merge his changes.

Comment 1 Vasiliy Sharapov 2011-04-07 16:13:44 UTC
Whoever this gets assigned to, while you're at it, you can probably take care of https://bugzilla.redhat.com/show_bug.cgi?id=681996

It's a one character change to the specfile of this package, also fixed in -26

Comment 3 RHEL Product and Program Management 2011-04-07 16:24:04 UTC
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 6 Adam Jackson 2011-06-21 16:02:28 UTC
Fixed in 1.7.7-29.  MODIFIED.

Comment 10 Dave Airlie 2011-11-11 14:47:03 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description necessary, internal RH bug.

Comment 11 errata-xmlrpc 2011-12-06 14:38:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1602.html